0
$\begingroup$

I encountered a very frustrating problem in not being able to totally smoothen out my mesh, whatever I try. It seems that for some edges of the mesh, there's a stubborn sharpness data that won't go away whether I try to clear sharp, reset normals, clear custom split normals data, or turn Auto Smooth off.

So, as a starting point:

I have my mesh, I have applied smooth shading to it. In edit mode, there's no sharp edges marked. Auto-smooth is not enabled, and there should not be any custom split normals data, as it shows in the menu the option "Add Custom split normals data". Also, the mesh is not using any modifiers. In my experience, the mesh should look totally smooth now?

Still, there are some edges in my meshes that look sharp, and/or there's just something weird going on with the normals:

enter image description here

Next step:

The normal fix I would in a situation like this, would be to go to edit mode, select all vertices and hit alt + N to open up the Normals menu. Then hit 'Reset Normals' hoping that this would reset the normals to their default state so that the smooth shading would work normally and I could get rid of the incorrect shading. But, instead of that, the following things happen:

  1. All those sharp-looking edges I can't get rid of, get marked sharp
  2. Auto-smooth gets enabled
  3. some custom split normals data gets added, as the menu now shows "Clear custom split normals data"

enter image description here

And as a result those edges look even sharper than before.

Then, I try to cancel everything what happened, by:

  1. Selecting all edges in edit mode and hitting 'Clear Sharp'
  2. clearing custom split normals data
  3. turning auto-smooth off.

And as a result, I'm at the starting point again. Those pesky edges still appear sharp. Repeating any of these steps in different order doesn't work either.

One interesting detail might be, that the mesh is imported as FBX from another Blender project. Could this be the reason? Is there some normal data written in FBX that can't be rewritten in same way as you would normally do, using the above methods?

$\endgroup$
4
  • $\begingroup$ Please share your Blend file via blend-exchange.com following the instructions there so that we can look at it directly. Have you tried increasing the Angle setting on the Normals panel with Autosmooth enabled $\endgroup$
    – John Eason
    Mar 3, 2023 at 12:47
  • 1
    $\begingroup$ Hi John! Yes, I have tried increasing the angle setting. It affects everything else in the mesh, except these specific edges that have the problem. I'll share the blend file in a sec. $\endgroup$ Mar 3, 2023 at 13:24
  • $\begingroup$ Here's the file: <img src="https://blend-exchange.com/embedImage.png?bid=D5XpKw4Q" /> $\endgroup$ Mar 3, 2023 at 13:43
  • $\begingroup$ I suspect that most of the problem is due to poor topology of the basic mesh. Try adding a Subdivision Surface modifier with Level set to 1 and apply it. Is that good enough? $\endgroup$
    – John Eason
    Mar 3, 2023 at 14:25

1 Answer 1

1
$\begingroup$

It's a known problem of AO (Ambient Occlusion) to produce artifacts most prominent on low poly meshes… In particular, by definition AO darkens creases and lightens edges, and the simplest way to produce the problem is to set shade smooth on the default cube:

What causes the weird shading when you smooth shade a cube?

As you can see there, even though the cube is shaded smooth, AO pronounces the edges.

So turning AO off is the solution to smoothness:

If you actually want AO, I think it deserves another question on how to produce it on low poly, maybe by just baking it to a texture/vertex attributes…

$\endgroup$
1
  • $\begingroup$ Ah, that's it. Thank you for finding the culprit! It just didn't cross my mind that AO would cause this. $\endgroup$ Mar 5, 2023 at 4:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .