1
$\begingroup$

Does anyone know why I get this error when trying to preview or render with Blender 3.5 Beta with OSL and light tree enabled?

OSL group data size (2296) is greater than the maximum supported with OPTIX (2048)

And nothing gets rendered. How do I increase that data size pool and make it work?

$\endgroup$
4
  • $\begingroup$ Is it practical to include the OSL script in your post? $\endgroup$
    – Robin Betts
    Mar 2, 2023 at 18:42
  • 1
    $\begingroup$ Not sure what you mean. I'm just using stock 3.5 build from Blender website with "OSL" checkbox checked. Did not add any other scripts anywhere. $\endgroup$ Mar 2, 2023 at 18:46
  • $\begingroup$ Sorry.. I thought, if you had OSL checked, it you would be to run OSL Shaders . I'm not aware of another reason to do it, but am open to correction. $\endgroup$
    – Robin Betts
    Mar 2, 2023 at 19:30
  • 1
    $\begingroup$ See maybe #104304 - OPTIX OSL Group size error - blender - Blender Projects $\endgroup$
    – L0Lock
    Mar 2, 2023 at 19:55

1 Answer 1

-1
$\begingroup$

Under Render Settings uncheck Open Shading Language setting.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .