0
$\begingroup$

I'm new to Blender and have been trying out the PBR Material, problem is when I tried to render this material in Cycles, somehow it became transparent ??? I've checked the blend mode of it and it is "opaque". This material can be rendered just fine in Eevee. Can someone help me out ? Thanks !!!

Material rendered in cycle Material rendered in eevee

Here is the blender file if you need to take a more detailed look

$\endgroup$

3 Answers 3

0
$\begingroup$

This texture: PaintedMetal004_1K_Opacity.png is missing in my file. It provides the transparency information. Eevee disregards it, unless you specifically tell the material to include it. Check the texture, from your screenshot I think it's way too bright in general. You can always add a color ramp in between to control it in real time

$\endgroup$
1
  • $\begingroup$ Yes, about the missing PBR Material. Here is the packed blender file (hope this helps) drive.google.com/drive/folders/… Thanks for you advice though! from your comment, (for clarification) do you mean i should try using the color ramp for the texture used in the Alpha input ? $\endgroup$
    – LilFox4112
    Mar 6, 2023 at 6:08
0
$\begingroup$

It would seem that when opening your .blend file, none of the PBR material images are present, so testing for the exact problem your experiencing is made more difficult. You can pack/include all of your textures in your .blend file by selecting File -> External Data -> Pack Resources. However, bear in mind that this will increase the size of your project file and you will need to respect any copyright that may apply to your texture images when distributing them.

$\endgroup$
2
  • $\begingroup$ Oh, i didn't know about thattt!!! I've tried following your steps to include the material! Should be fine according to the website license. So, here is the PBR Material file (i hope you don't mind the google drive link). Hope this helps to solve the problem! drive.google.com/drive/folders/… $\endgroup$
    – LilFox4112
    Mar 6, 2023 at 6:05
  • $\begingroup$ It looks like the solution is to add a ColorRamp node in between the texture and the Alpha input on the Principled BSDF shader node as suggested by @Frederik Steinmetz. You will probably want to slide the white colour bar all the way nearly to the left to see a difference. You may also want to add a color Invert node after the ColorRamp node if you want to reverse the transparency. $\endgroup$
    – KingsDnT
    Mar 7, 2023 at 13:22
0
$\begingroup$

The object renders fine in Eevee exactly because the Blend Mode is set to Opaque. If you set it to any of the Alpha options, it will be transparent in Eevee as well as in Cycles. Incidentally, Blend Mode is Eevee only and has no effect on Cycles materials.

To get rid of the transparency, disconnect the noodle connected to the Alpha input of your Principled shader. If there is supposed to be transparency in the material, just different from how it appears here, then there must be an issue with whichever texture drives the Alpha input

$\endgroup$
2
  • $\begingroup$ Thanks for your input! yes, i've tried to disconnect the noodle connected to the Alpha input, it appears to have solved the transparency problem. Shame that the black spots from the texture disappeared instead. It seems that cycle rendered this black and white texture as transparent instead. Do you have any input on how to prevent this problem with the Alpha input ? would changing the alpha texture color from black and white to other color help ? Thankss $\endgroup$
    – LilFox4112
    Mar 6, 2023 at 5:54
  • $\begingroup$ as a follow up to my previous comment, here is the packed blender file if you need to take a closer look to the PBR Materials, I appreciate the help $\endgroup$
    – LilFox4112
    Mar 6, 2023 at 6:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .