0
$\begingroup$

I'm following an online tutorial for creating a looping animation and I was instructed to set animation to Linear under Default Interpolation so the speed will be constant, but although I did as I was told, my animation still slows down at the end before the loop resumes. I tried using Constant Interpolation, but that also had no effect.

I'm sure I'm doing something wrong somewhere, but is there a chance that there's another setting somewhere I need to adjust? I'm using version 3.4.

$\endgroup$
4
  • $\begingroup$ Where did you change the setting? It sounds as if you may have only changed one keyframe rather than all of them. I usually select all of them with A in the Timeline then right-click and choose Interpolation Mode > Linear. $\endgroup$
    – John Eason
    Feb 26, 2023 at 19:22
  • $\begingroup$ The changing of the default interpolation in the user preferences of course has to be done before you set any keyframes. If you have inserted keyframes before changing the default, they will stay as they were. Only keyframes inserted after changing the default will automatically have linear interpolation. Apart from that, as @JohnEason said, make sure to select all, then press T and choose Linear. And if it still seems there is something wrong, just go to the Graph Editor. If you see something that doesn't look linear, then it's most likely not set to Linear. $\endgroup$ Feb 26, 2023 at 19:51
  • $\begingroup$ Mr. Eason, that worked PERFECTLY! Thank you very much! Mr. Brinkmann, thank you for your explanation- that made things clearer. :) $\endgroup$ Feb 26, 2023 at 20:21
  • $\begingroup$ Good! As @GordonBrinkmann says, you can also press 'T' to bring up just the Interpolation menu, but I tend to use right-click for almost anything. $\endgroup$
    – John Eason
    Feb 26, 2023 at 23:14

0

You must log in to answer this question.

Browse other questions tagged .