0
$\begingroup$

newbie here. When I try to do Unwrap in UV layout, I can't because the option is missing from the menu bar.

I am in edit mode and I apply a new material image texture (jpg), but once I do that and go to UV layout to make the texture unwrap (or smart uv), the Unwrap option doesn't show up. The layer I am applying the texture on is a curve. How to enable the option?

P.S. I tried the shortcut A -> U, but still nothing.

I am using the latest mac version of Blender, 3.4.1 (3.4.1 2022-12-20)

enter image description here

$\endgroup$
7
  • 1
    $\begingroup$ Hello could you please show a screenshot of your whole interface? $\endgroup$
    – moonboots
    Feb 22, 2023 at 15:30
  • 2
    $\begingroup$ Hello and welcome. Curve can't be UV unwrapped in the traditional way of using U menu >unwrap... If you want to use that, you need to convert the curve to mesh $\endgroup$
    – Emir
    Feb 22, 2023 at 15:37
  • $\begingroup$ @moonboots here you go imgur.com/a/sYEtkXQ it's a wall with a wooden texture (jpeg) that is distorted, and I am trying to unwrap it so it fits nicely to the shape. Emir, I believe that, but somehow I managed to do it once with this same shape being curve and not mesh? $\endgroup$
    – Greg
    Feb 22, 2023 at 17:04
  • $\begingroup$ For the moment you're not in Edit mode, so you can't see any UVs, switch to Edit mode and select all? $\endgroup$
    – moonboots
    Feb 22, 2023 at 17:26
  • $\begingroup$ I think I am? imgur.com/a/kVqZfS7 $\endgroup$
    – Greg
    Feb 22, 2023 at 17:37

1 Answer 1

0
$\begingroup$

Your object is a nurbs curve, not a mesh, you can't unwrap a nurbs curve. To convert to mesh, select it, right click > Convert To > Mesh, then unwrap.

$\endgroup$
1
  • $\begingroup$ That solved my problem. Thank you, much appreciated. $\endgroup$
    – Greg
    Feb 22, 2023 at 18:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .