I am having an issue with X-ray mode. When I am in Material preview viewport, I turn Xray on and objects don't display as see-through like default settings. enter image description here But if I switch my workspace to UV editing, it displays the see-through view again. enter image description here

I guess I adjusted some settings (or even addons that I set up, been switching to Blender for 3 weeks).

Still I am wondering how to get the X-ray react like the first case, so maybe in the future, there can be some use case for that (select backface elements while still keep the opacity solid)

  • $\begingroup$ That's an interesting question, I would like to know the answer as well. I know that X-Ray in Material Preview is disabled when you're in Object Mode, and even in Edit Mode you can only see the selected object, but not others behind or inside it. The only difference I can see here is in the first screenshot you're in Vertex Select mode and below in Face Select mode, but that shouldn't make a difference. I guess without seeing all your settings or inspecting your file I cannot find a reason for this. But is it reproducable or was it just once? Might have been some glitch or bug. $\endgroup$ Feb 22 at 9:00
  • $\begingroup$ When I'm in Material Preview mode and I click the Toggle X-Ray button a message pops up in the bottom bar saying "X-Ray not available in current mode" Also, as a side note, for some reason in the drop-down menu, the setting for X-Ray seems backwards to me. 0.0 = fully transparent, and 1.0 = fully opaque... Just something to be aware of. $\endgroup$
    – Psyonic
    Feb 22 at 11:21
  • $\begingroup$ @Psyonic The message appears when in Material Preview and Object Mode, the button is greyed out as well. When you switch to Edit Mode you can turn on X-Ray, however it is limited to the selected object - i.e., you can see the hidden geometry of the object you're editing, but not the other objects inside or behind it (just as I said in my comment before). About the "backwards" problem: the slider is an alpha value, not the opacity percentage. It works like all alpha channels: 0 = transparent, 1 = opaque. If you are not sure what a slider does, you can use the mouseover help. $\endgroup$ Feb 22 at 21:45
  • $\begingroup$ @GordonBrinkmann I understand, I was just remarking that the value it adjusts the alpha of is called "X-Ray", therefor a higher number "should" be "more" X-Ray... Just my humble opinion. Perhaps it should be called "Opacity" rather than "X-Ray"? $\endgroup$
    – Psyonic
    Feb 23 at 5:48
  • $\begingroup$ @Psyonic It is called "X-Ray" to indicate that the slider is relevant for X-Ray mode. Below is the "Shadow" slider for example, also an opacity slider. Actually most sliders that deal with transparency in some way are opacity sliders even if it is not stated there - since most of them are using alpha transparency, where 0 is transparent and 1 is opaque. An exception are the Glass BSDF and the Transmission channel of the Principled BSDF, because transmission is something different than alpha transparency, it can be refractive, blurry etc. whereas alpha is just how much see-through it is. $\endgroup$ Feb 23 at 6:54


You must log in to answer this question.

Browse other questions tagged .