1
$\begingroup$

I have a blender 3.4 file with a cloth animation.

  • I run the simulation in the Layout panel : it works.
  • I render the whole animation : It work(ed).

Then I tried to add baking. It didn't go the way I wanted, so I removed the baking.

Disaster!

  • Now the simulation still runs propery in the Layout panel, BUT
  • The rendered animation is all broken: Each frame is "mixed" with the vertices of the first frame. I can distinctly see the shape of frame 1 in every subsequent frame.

enter image description here

I tried :

  • I tried the obvious : "Delete all bakes" followed by "Bake all dynamics".
  • "Delete all bakes", followed by : Go to frame 1, then "render to frame".
  • Close and re-open Blender.

What's going on? (See picture : top-left = the expected result, middle = you can see the two frames "mixed" together, right = my bake settings)

Please note that it says "X frames in cache" because it recalculates them every time I play the animation in the Layout panel.

Extra troubleshooting : Around the time the issue appeared, I Changed the FPS (12 instead of 24) and the "step" setting (4 instead of 1). I also did a time remapping (100 to 200). When I saw that I was having problems I reverted every changed to original values.

$\endgroup$
5
  • $\begingroup$ You must bake before rendering. Calculations will work correctly only when done in one go, which is why it works when playing from the viewprot and not in rendering. Baking is what makes sure the simulation is done once for all and doesn't "change" one frame to the other when rendering or wshipping your assets elsewhere. What exactly went wrong when you tried baking? Also, this is an english-speaking website, please don't sent content in english if you want people to understand. $\endgroup$
    – Lauloque
    Feb 20, 2023 at 16:57
  • $\begingroup$ I did bake before rendering: When I noticed that the rendering was now broken, I tried every possible order: Delete All bakes, then recreate bake, then render. Delete, then play whole animation in viewport, then render. Etc. Nothing worked; always these mixed vertices in the render. Answering your question: Nothing went (really) wrong when I tried [explictly] baking, I just changed my mind because the physics simulation was no longer including the wind (I assumed in was a Blender oddity). I reverted to "baking as I go" by playing the animation entirely first in the viewport. $\endgroup$ Feb 21, 2023 at 10:57
  • $\begingroup$ Perhaps time to use File::Recover::Auto_save? $\endgroup$
    – james_t
    Feb 21, 2023 at 21:46
  • $\begingroup$ I copy-pasted everything into a brand new file and the problem remained. However, I think I might have this issue : blender.stackexchange.com/questions/15706/… Like I said I've had the "surface division" modifier since the beginning and it wasn't a problem but this compels me to have a closer look. $\endgroup$ Feb 22, 2023 at 15:51
  • $\begingroup$ @james_t see the answer I've posted. Any thoughts on that? $\endgroup$ Feb 22, 2023 at 16:06

1 Answer 1

1
$\begingroup$

This issue was a duplicate of Cloth simulation appears corrupt in render

The problem was that the "Surface Subdivision" modifier had a different setting for Levels Viewport and Render as seen here :

enter image description here

How to fix : I had to set both values to "1", delete all bakes, then bake all dynamics. I guess there was a discrepency between the simulation cache for the viewport and the cache for the render.

enter image description here

Ending note :

For future readers.

Now there's a new problem : It's useless to have surface subdivision set to 1. I should be able to set it to "2" at least. But when I try to set it to "2" in both Viewport and Render, the problem has changed:

  • The mesh no longer appears "broken" like in the oroginal question (the simulation cache worked!). That's good, BUT
  • The wind is no longer simulated. The cloth falls down and "ignores" the wind's Force Field objects. I can only extrapolate the root cause : Maybe the simulation settings I have created for a subdivision of value "1" only apply to "1" and don't apply to "2"? That must be a weird Blender "feature" rather than a bug. I need to investigate how Blender works, but that's a problem for another question.
$\endgroup$
1
  • 1
    $\begingroup$ There are other side-effects/problems when View != Render in subdivision, such as with SurfaceDeform modifier. Good find! Hope you didn't pull all your hair out. Blender -- as with all 3d modeling software, is quite challenging and arcane! $\endgroup$
    – james_t
    Feb 22, 2023 at 16:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .