0
$\begingroup$

Previously Blender used to zoom in and out when I use the wheel or touchpad two-finder gesture, but now it just orbit the view instead after the last few updates (since 3.2 or 3.3), and I don't remember changing any keymaps. In fact when I went to keymaps (even though it's frustratingly burried in a ton of contextual shortcuts) the 3D view zoom is set to [wheels]

enter image description here

It's really not the best set-up for me, can anyone confirm if the default keys have been changed and how can we restore them to old behaviour, thanks.

EDIT: I'm using Emulate 3 Button Mouse BTW

Navigation preferences: enter image description here

$\endgroup$
5
  • $\begingroup$ Can you add an image of the Edit > Preferences > Navigation tab. $\endgroup$
    – John Eason
    Commented Feb 17, 2023 at 23:06
  • $\begingroup$ @JohnEason I added it $\endgroup$
    – Sami Ben
    Commented Feb 17, 2023 at 23:16
  • $\begingroup$ This could just be my preferred settings (under W10 with full keyboard and set up many moons ago), but I have Orbit Around Selection, Auto > Depth and Zoom to Mouse Position checked here. That's been the same right back to version 2.83 as far as I can remember. $\endgroup$
    – John Eason
    Commented Feb 17, 2023 at 23:21
  • $\begingroup$ @JohnEason It's the Microsoft Precision drivers, when I changed it to the device OEM drivers (Alps) it resolved the issue. $\endgroup$
    – Sami Ben
    Commented Feb 18, 2023 at 15:21
  • 1
    $\begingroup$ Ah ok. I wonder if that's because the MS drivers are giving faulty outputs or because Blender is interpreting them incorrectly? Might be worth reporting it as a possible bug in case the Blender developers aren't aware of the problem. $\endgroup$
    – John Eason
    Commented Feb 18, 2023 at 15:34

1 Answer 1

1
$\begingroup$

You can zoom in and out using the mouse wheel, + and - keys and middle mouse button dragging while holding Ctrl down in Blender by default. Mouse wheel works fine by default. That has not changed in current version that is 3.4.1 at the moment. There must be some issue with your setup. Try making sure you have correct drivers and settings for your touchpad and that it works correctly. You could go to File -> Defaults -> Load Factory Settings to see if it works correctly with Blender as it comes with fresh installation. Be careful not to override your user preferences if you care about them(you could also make a backup copy of %appdata%\Blender Foundation\Blender\3.4)

$\endgroup$
4
  • $\begingroup$ Nope, I did it, same thing. I should note that I'm using 3 Button Mouse Emulation cuz I'm using a touchpad, maybe it's behavior changed recently, can you try turning it on? $\endgroup$
    – Sami Ben
    Commented Feb 17, 2023 at 23:24
  • $\begingroup$ Still works. Could be something wrong with the touchpad or its drivers or maybe its settings. What kind of touchpad is it? Some of them come with fancier drivers and some settings that are possible to change, maybe look into that. Other that that I would really recommend using a mouse. There is no reason not to. You can get one for 10 euros or less. $\endgroup$ Commented Feb 18, 2023 at 8:54
  • $\begingroup$ Microsoft Precision drivers, when I changed it to the device OEM drivers (Alps) it resolved the issue, it looks like the MSFT drivers are the culprit indeed. thanks. $\endgroup$
    – Sami Ben
    Commented Feb 18, 2023 at 15:20
  • $\begingroup$ Just out of curiosity - why don't you use a mouse? $\endgroup$ Commented Feb 19, 2023 at 1:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .