5
$\begingroup$

I'm trying to create whiskers of a hairy animal, and I can't found a way to keep the whisker's hair particle close enough to the mesh.

Here is an illustration:

enter image description here

It's not a mesh instance, I'm using the Cycles Hair Rendering with a "curve segment" primitive and "Thick" shape.

Is there a way to get rid of the offset between hair's start and the emitter mesh?

I've tried to reduce the velocity and increase the length, but both seems to do the same, increasing offset.

$\endgroup$
  • $\begingroup$ Are you using a mesh? If so, extrude the bottom loop downwards well below the mesh origin. $\endgroup$ – VRM Apr 19 '15 at 12:55
  • $\begingroup$ Nope, it's a "built-in" hair particle (Thick Curve Segment of Cycles Hair Rendering) I edited my question. $\endgroup$ – Polosson Apr 19 '15 at 13:01
11
$\begingroup$

Well, I finally found what goes wrong. It's simply due to the particle settings: I checked "B-spline" in the "render" section, which interpolate hairs shape using B-spline, and induce a shift between the root vertice of hair and its actual rendered root.

enter image description here

I thought using this setting be useful to have smooth shaped hairs, but in fact using "Curve segment primitive" (Cycles Hair Rendering panel) is sufficient and works great !

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ You just saved my day, spent two hours on the same issue! $\endgroup$ – B-and-P Mar 29 '17 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.