I have a series of geometries I created in Fusion 360 using parameterized models which I am using to create the underlying geometry for a 3D printed board game I am making to play with friends. Most, if not all, of the parts will need to have surface texture added to them which I am attempting to add in Blender. I have tried a number of approaches and am getting so close however I am still running into issues that I can't seem to resolve.

The issue currently is that my textures I am using (in this case a wall pattern acquired from poly haven), are being stretched out and look nothing like what they are suppposed to look like.

What follows are the steps I take from start to finish.

  1. Import STL enter image description here
  2. Edit Mode->Select Faces I would like to add the wall texture to (I have tried multiple faces but for simplicity I will select only one for this example), and use P-Selection to Separate and Name Wall_A and switch back to Object Mode enter image description here 3.Modifier Properties -> Add Modifier -> Remesh, Voxel to default (see screenshot) enter image description here
  3. Texture Properties -> Image or Movie ->Open to load in my brick displacement texture. Rename to 'Brick Wall' enter image description here
  4. Modifier Properties -> Add Modifier-> Displace, then browse to Brick Wall Texture and this is what I get. enter image description here From here I have tried adjusting all the selectors and values in both the displacement menu, as well as the corresponding texture menu corresponding to this texture. Everything I have tried has made this only worse and never better. The texture appears to be rotated and stretched. I have tried selecting UV mapping and through some other tutorials I have a loose idea of how to use that tool however the UV map doesn't appear in the UV editor menu (which likely is just a product of my being new to this software as I just started using it 48 hours ago).

If there is a solution to scaling and rotating my texture to my model I would super appreciate it, additionally if there is a simpler way of doing this I am certainly open to hearing it, though of all the methods I have looked into this has been the only one I have gotten to work "well".

Of note, I am sure I will get (based on other answers I have seen) feedback such as "don't use your stl from Fusion 360, just build this in Blender. To which I will respond that this is just one of the many models I have built in Fusion 360, many of which are fairly complicated, parameterized models which allow me to rapidly create Length x Width interlocking blocks and panels and integrate circuit boards. As I understand it, without an addon, Blender isn't particularly well suited for that type of implementation (although I am very well versed in Python so I am not completely opposed to recreating all these models in Blender using Python to implement the parametrization). Having said that, it seems as though I am so close to achieving what I want to do here without having to rebuild all my parametrized models in this program.

  • $\begingroup$ Did you apply the scale to your model (Ctrl-A in Object mode) and then UV unwrap it after importing? $\endgroup$
    – John Eason
    Feb 16 at 17:53
  • $\begingroup$ I pressed Crtl-A, and selected scale and nothing happened. Also I am concerned that the UV unwrapping might render the remesh innaplicable when it comes time too do the displacement, is that correct? $\endgroup$
    – Matthew
    Feb 16 at 19:38
  • $\begingroup$ If you press 'N' in 3D view to display the side panel and click the 'Item' tab, you will see the Scale entry under Transform. All 3 Scale entries should be 1 when the scale has been applied. UV unwrapping should be done after any mesh modifications. $\endgroup$
    – John Eason
    Feb 16 at 23:01


You must log in to answer this question.

Browse other questions tagged .