I am new to Blender and trying to learn the controls. There is a fundamental thing I don't seem to get right: Deselecting.

I tried clicking into empty space, I tried going in the menu select->none but I always get the same result: yes, all objects get deselected, however, the active object stays the active object. In the properties Area I can still edit it even though it's unselected and its origin is still highlighted in the viewport.

Steps to reproduce:

  1. Select the default cube.
  2. Click into empty space.

The default cube is still the active object. It's still editable in the properties window and its origin is still highlighted.

I find this extremely infuriating and confusing. It keeps looking like the object is selected and I can never get a good unobstructed view of my scene because I keep seeing its origin.

What do I have to do to clear the active object?

  • $\begingroup$ Stupid question on my behalf: I've made a few suggestions in my answer, maybe not perfect. But since I'm most of the time working on one or more objects in either Edit Mode or Object Mode, there are almost all the time selected objects so I never needed to "clear" the active object. Or what do you mean by getting "a good unobstructed view"? Maybe disabling the overlays completely is what you want? $\endgroup$ Feb 12, 2023 at 17:56

1 Answer 1


It seems like in Blender it is not intended to simply deselect an object to make it no longer being the active object. But I might be wrong and others are welcome to bring up another solution. Here are some more or less helpful ways to get rid of the active objects origin or status.

Generally you can of course hide the origin in the viewport by hiding the active object in the viewport with H. But it's still editable in the properties tabs.

If it is the origin in the viewport that bothers you, generally you can of course deactivate the origins in the Viewport Overlays. However, then it will never show any origin no matter if an object is selected or not, so that's maybe not what you want:

viewport overlays

Another more radical way would be: select an object so it becomes the active object and delete it with X. Or add an object and directly delete it. Then only the other "passive" objects are left in the scene, none of the remaining will automatically become the active one. Of course not the best way either.

A third way without deleting an object (or just adding one to delete it) would be to exclude the collection containing the active object from the view layer by unchecking the checkbox. If you directly check it afterwards, all objects in this collection have become passive objects:

exclude collection

All these ways are not the most comfortable for such a seemingly simple task, but as I said, maybe someone else has a better idea. I never tried to explore this further since it never bothered me.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .