0
$\begingroup$

I couldn't render a movie clip with a tracked object on it. I added Movie Clip and Render layers as inputs and Alpha Over as a node to combine images. But when pressing CTRL+F12 it seems like I see only Render layers in a view pane, no image from movie clip. What could be the nature of the problem? I've tried disabling Sequencer in Post processing section of Output properties.

Here is a short video of the problem: https://i.imgur.com/eesgWvW.mp4

Any suggestions would be very helpful for me. I used https://blender.stackexchange.com/a/188346/2980 as a guide.

I'm using Eevee render engine.

composition

$\endgroup$
3
  • 1
    $\begingroup$ Does the Render Layer have a transparent background? It looks all grey, a transparent background is indicated by a checkerboard texture... have you enabled Render Properties > Film > Transparent? If not, the Alpha Over node will not work because there is no transparency in your render where the movie clip can be seen through. $\endgroup$ Feb 10, 2023 at 21:01
  • $\begingroup$ @GordonBrinkmann that's the solution, much obliged! How could I accept your answer? $\endgroup$
    – aestet
    Feb 10, 2023 at 21:54
  • $\begingroup$ Wait for my answer to be posted ;) Comments cannot be accepted. But there it is, now you can accept the answer. $\endgroup$ Feb 10, 2023 at 22:21

1 Answer 1

1
$\begingroup$

Your rendered image has no transparent background as you can see by the grey color. If it were transparent, this would be indicated by a checkerboard and your Render Layers node should look like this:

transparent layer

To use the Alpha Over node, the background of the overlaying image has to be transparent in order for the underlying movie clip to be visible. To change it, go to Render Properties > Film and enable the Transparent option:

film transparent

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .