3
$\begingroup$

I have a school project for which I need to make a small movie in Blender. All the animations are fine, but the moment my camera gets into the airduct I made, the preview gets all dark and blurry. I tried to set the FOV but it didn't work. In the room before the camera works fine. I also added quite a handful of lights so I don't think it might be the problem.

Anyway here is the render preview. There is a point light just above the cube. Render

FoV Fixed

$\endgroup$
9
  • $\begingroup$ Using Cycles render engine? Make sure there is enough light in that part of the scene. Also, add a screenshot/render of exactly what is happening when it gets to the airduct. $\endgroup$
    – VRM
    Apr 17 '15 at 11:28
  • $\begingroup$ I am using cycles yes. I'll try to add more light but i wanted to created a bit dark/suspense atmosphere. Is it not possible ? Anyway i will post a screenshot when i have access to my pc (in around 3 hours 30) $\endgroup$
    – student
    Apr 17 '15 at 11:38
  • $\begingroup$ It is possible, I'm just guessing that is why it is "blurry", without a screenshot I can't be sure. $\endgroup$
    – VRM
    Apr 17 '15 at 11:45
  • $\begingroup$ I answered you in a new answer because stackexchange wont recognize me oncé im registered $\endgroup$
    – student
    Apr 17 '15 at 14:30
  • $\begingroup$ Don't post an answer that isn't one! I am going to move the image to the question and then delete the answer post. When you are signed in you can edit your own posts. About the image, it looks like the camera focus is messed up. Check under your camera settings and see if the Depth of Field box has a focus object in it. $\endgroup$
    – VRM
    Apr 17 '15 at 14:31
4
$\begingroup$

It seems that your focus point for the camera is attatched to some other object in the scene, so that when you get into the air duct, it is all blurry. There are several ways to fix this, the best one is to add an empty (Shift+A > Empty > Plain Axis). Name it Camera Focus or something descriptive so you can find it easily later.

Now select the camera and go to Camera Settings > Depth of Field and select your empty.

Add camera focus example

You can now animate the position of the empty, and the camera will automatically focus on that point, so you can have it positioned near where you want to focus while it is still in the room, and then animate it to move into the air duct.

If your preview image is still pixelated like that, try rendering at a higher sample count.

$\endgroup$
1
  • $\begingroup$ Thanks i fixed it by deleting the few cameras i found with no use and changed dof to fstop and it worked :D $\endgroup$
    – student
    Apr 17 '15 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.