0
$\begingroup$

so I'm new to using fire in my animations. I have a 4090 for GPU but wow my renders are taking so long for just simple fire burst animation. Are there settings I should be doing to get a faster render? My graphics card is extremely fast and this is just nuts. One frame is taking 20 mins.

Samples are 150 1920x1080

enter image description here

enter image description here

enter image description here

$\endgroup$
6
  • 3
    $\begingroup$ TBH volumetric shaders are some of the slowest things to render, so it isn't unexpected to have a significant increase of render time as soon as you add them in your scene. Now there are ways to optimize things here and there or even fake volumetrics to some degree. But it would help if you could share your file here using Blend-Exchange. Or at least post screenshots of your render settings and shaders. Ideally do both! $\endgroup$
    – L0Lock
    Feb 7, 2023 at 20:40
  • $\begingroup$ Ok posted some screen grabs showing shaders/render. $\endgroup$
    – Steve Cady
    Feb 8, 2023 at 2:37
  • $\begingroup$ Hmmm... I only have a 3060 but my fire renders don't take that long usually with 150 samples. But of course this is not only dependent on the render samples but also on the resolution of the smoke domain for example. How detailed is your fire animation? The more voxels per image, the longer the render time. Also motion blur slows down the render times. By the way, to not get frustrated after a long render and then seeing black artifacts in the fire/smoke, I would increase the Transparency bounces. That doesn't increase render times very much - I usually have them at 64 or 128. $\endgroup$ Feb 8, 2023 at 13:28
  • 2
    $\begingroup$ @SteveCady Have you tried rendering without Motion Blur? I just made a test render myself (on this computer I only have a 1060), 1920 × 1080 with 150 samples (and volume bounce at 1 and 128 transparency bounces) and it took only 1 minute 20 seconds - without Motion Blur. Now I enabled it and with Motion Blur the the render took 15:49 minutes. So from 80 seconds to 949 seconds is almost 1200%... quite a leap. $\endgroup$ Feb 8, 2023 at 14:36
  • $\begingroup$ I forgot: screenshots of your domains settings would absolutely help. The most sensitive setting is the domain's resolution if I remember correctly, also adaptive domain if you don't bake your simulation before rendering (which you should NOT do, especially when using motion blur), also noise i think, ... Motion Blur is definitely a big weight in render times. $\endgroup$
    – L0Lock
    Feb 8, 2023 at 22:11

1 Answer 1

1
$\begingroup$

The solution was turning off the motion blur. Huge time saver fix! Worst case if I'm desperate for motion blur for this moment I can add it in after effects. Thank you Gordon!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .