5
$\begingroup$

Since I updated to 2.74, sometimes the mouse wheel scrubs the timeline rather than zooming. I guess I've hit some key by mistake, but I haven't been able to find out which one. When this happens, scrolling scrubs the timeline no matter which part of the UI I'm in, i.e. it won't let me scroll up and down in the panels either.

Update: I have several virtual desktops, and after posting this, when I went back to the desktop where Blender is, it had reset the mouse function to what I'm used to. Seems strange. Is this a bug that I should report, or is it some feature that I haven't been able to wrap my head around?

$\endgroup$
  • 1
    $\begingroup$ It could be the OS causing the problem. Could be drivers. Could be Blender. Without concrete steps that can reproduce the problem, the report will be closed right away unless many people are all saying the same thing. The best thing that you can do for yourself is to find some action or series of actions that will reset Blender's grip on user input/output so you can get back to what you are doing. Maybe push the escape key several times, or double click the header bar, try Ctrl-S then Ctrl-O to save and reopen, etc.... $\endgroup$ – MarcClintDion Apr 17 '15 at 4:48
  • $\begingroup$ @MarcClintDion I'll try to make notes of what I was doing right before it happens, and see if there's a pettern to it. I'll also consider contacting the maintainer of the FreeBSD port and the maintainer of the window manager I'm using, but I'll try gathering some more data first. Should we put this on hold for now, or should we leave it open? $\endgroup$ – user7952 Apr 17 '15 at 5:16
  • $\begingroup$ For me, ever since I upgraded to Yosemite(OSX), whenever I switch between the IRC app(Colloquy) and Blender's Node Editor, the movement of the Node Editor becomes "attached" to the OS mouse cursor. When I move the tablet pen around, the Node Editor goes bonkers and jumps all over as if I'm left-clicking and dragging while jerking the pen around violently, even though I already released the button and hardly move the cursor. It's really bonkers and only seems to happen between the switch from the IRC window to Node Editor. For three years it never happened and now it happens every time. :) $\endgroup$ – MarcClintDion Apr 17 '15 at 12:29
  • $\begingroup$ I believe this one is related. $\endgroup$ – user7952 Apr 28 '15 at 20:10
  • $\begingroup$ I have the same problem! On Ubuntu not using a virtual machine. $\endgroup$ – Felix Crazzolara Nov 20 '17 at 22:54
3
$\begingroup$

In different windows, Alt + scrolling the wheel scrubs the timeline. Hope it's an helpful info.

$\endgroup$
  • 2
    $\begingroup$ If I hold Alt while scrolling the wheel nothing happens. Nothing at all. And even if it did, I don't think it'd solve my problem, because my problem is that it locks itself to scrubbing the timeline. $\endgroup$ – user7952 Apr 16 '15 at 18:26
  • $\begingroup$ this doesn't work for me either. I tried hovering over several window types to see if this made a difference. $\endgroup$ – MarcClintDion Apr 17 '15 at 4:59
  • $\begingroup$ Alt+scroll works in the compositor for me, but this still doesn't answer the question imo.. $\endgroup$ – gandalf3 Apr 18 '15 at 5:57