2
$\begingroup$

I have recently found a strange behaviour in Blender: sometimes when I delete certain objects in the scene, the JSON exporter becomes unavailable. For example in my actual scene, if I delete a specific plane it becomes unavailable, but not for any other meshes. Impossible to delete that plane.

However I can delete it with certain other specific objects, at the same time, and the exporter becomes available again. This as well only works with certain objects. Also, when the JSON exporter becomes unavailable, the same always happens for Motion Capture (.pvh) and Stanford (.ply) format export options. I have studied parent and material relationships but I haven't been able to find any logic in that behaviour.

What am I doing wrong ?

(This is a copy from this SO question)

$\endgroup$
  • $\begingroup$ When you start Blender from a terminal / command prompt, Do you get any printed messages when you're doing any of this? Does this only happen if the io_three addon (three.js) is enabled, and is the addon the most up to date? $\endgroup$ – zeffii Apr 17 '15 at 6:09
2
$\begingroup$

Well i forgot to post the answer i found : the 'strange behaviour' was in cases i had no objects selected actually, that is why the exporter was not available. I dont know if this condition existed in the previous exporter too, maybe that was what lead me to ask.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.