2
$\begingroup$

I have a png image with alpha with transparen areas. I am rendering it with transparent backgraund adding red background in compositing, but black pixels appear on edges of shape on image. How can I remove those black pixels? .
File with image used:

enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ Hello could you please pack your image and share your file? $\endgroup$
    – moonboots
    Feb 6, 2023 at 10:25
  • $\begingroup$ yes its here fileup.to/5ioj/ground.zip $\endgroup$
    – Hanya
    Feb 6, 2023 at 10:27
  • $\begingroup$ thanks but you first need to pack your image (File > External Data > Pack Resources) $\endgroup$
    – moonboots
    Feb 6, 2023 at 10:39
  • $\begingroup$ And please upload the file with the packed image here: blend-exchange.com and follow the instructions there instead of some external source where we have to wait before we can start the download. $\endgroup$ Feb 6, 2023 at 10:48
  • $\begingroup$ thanks i packed it here: <img src="https://blend-exchange.com/embedImage.png?bid=aqNMosaY" /> $\endgroup$
    – Hanya
    Feb 6, 2023 at 10:52

1 Answer 1

3
$\begingroup$

The Denoise function in Blender is quite good, but it cannot do magic. You have set the Max Samples for Render to 1. This is very low. Increasing it to 2 is still very low, but gets rid of the artifacts.

render samples

Apart from that the low samples make your texture very blurry. Compare the left image at 2 samples with the one on the right at 50 samples (especially the area pointed at). And the render with 50 samples took only 0.2 seconds longer.

samples comparison

$\endgroup$
7
  • 1
    $\begingroup$ Thank you so much! It looks so much better now, very helpful information! $\endgroup$
    – Hanya
    Feb 6, 2023 at 11:18
  • $\begingroup$ @Hanya And beware that although in my example 2 samples were enough to get rid of the artifacts, this is because I rendered at a size of 50% as your render settings were in the file. At 100% the texture will have a higher resolution and then there is more potential for noise/artifacts, 2 samples are not sufficient anymore. So you have to find a balance between low samples to reduce render times but enough samples to get rid of artifacts. $\endgroup$ Feb 6, 2023 at 11:31
  • $\begingroup$ I always struggle when doing renders, and now knowing all you said will make me more comfortable when doing renders. I will try ro find the balance, thank you! $\endgroup$
    – Hanya
    Feb 6, 2023 at 11:43
  • $\begingroup$ @Hanya Some people even consider 500 samples still low, for my renders 200 samples are sufficient most of the time. But there's other things as well in your file, for example the Light Paths > Max Bounces settings in the Render Properties. They are all set to 1 except for Volume and Transparent. As soon as you are going to render things like glass, the Glossy and Transmission bounces are far too low to give good results (and then you have to increase Total as well), and if you put more objects with alpha transparency in a scene, the Transparency at 10 is very low, too. $\endgroup$ Feb 6, 2023 at 12:06
  • $\begingroup$ Its because I was rendering animation, so I realy wanted to have as short render time as possible. (i used some youtube video to help me shorten the time) $\endgroup$
    – Hanya
    Feb 6, 2023 at 12:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .