0
$\begingroup$

I knew how to do this once but for the life of me I can't remember:

I have an object that on frame 1 has a keyframe, and on frame 12 has another keyframe (let's call it a translation from 0,0,0 to 10,10,10).

How do I make it so the object continues along the same trajectory at the same velocity, without having to add more keyframes?

I thought this was done with an F-Curve Modifier but I can only seem to loop the animation, not keep it moving forward.

$\endgroup$

1 Answer 1

3
$\begingroup$

You are correct, you can do it with an F-Curve Modifier: Cycles. But instead of the default setting Repeat Motion as _Before Mode and After Mode, switch them to Repeat With Offset. But you have to do it on each curve. Or you do it in the Action Editor (see below).

Repeat Motion:

repeat motion

Repeat with Offset:

repeat with offset

Another way would be to do it in the Dope Sheet editor, this way you can set the F-Curve Modifier for all channels at once. Switch the editor from Dope Sheet to Action Editor. Right-click on the Object Transforms action and choose Extrapolation Mode > Linear Extrapolation or with the action selected, choose the extrapolation from the Channel menu:

action editor

The difference is, there are no modifiers on the curves in the Graph Editor. And the Action Editor can only make the action linear or cyclic, you have not the same modifiers as in the Graph Editor like Noise etc.

$\endgroup$
4
  • 1
    $\begingroup$ I knew it was that simple! Thanks Gordon, it was the "After Mode" setting that I was overlooking. $\endgroup$ Commented Feb 6, 2023 at 2:42
  • 1
    $\begingroup$ Curious- if I use the Action Editor, is there anywhere in the project that denotes I've done this? Or is this one of those silent settings that you have to remember you've changed. $\endgroup$ Commented Feb 6, 2023 at 2:43
  • $\begingroup$ @GlenCandle I have to admit that I never use the Action Editor because most of the time when I'm doing animations there is no need for repeating actions or moving actions along the timeline, so I'm no expert for this. I'm already baffled that the Action Editor at home in the screenshot looks different from what I see here at work, same Blender version. Anyway, I cannot see the slightest information in the editor that I've set a linear interpolation, only the graph shows that. And when it's linear there's not even a modifier of any kind (Make Cyclic at least adds a modifier). $\endgroup$ Commented Feb 6, 2023 at 7:06
  • $\begingroup$ Ha, another one of Blender's quirks I guess. I started using Blender when 2.8 came out, and I have learned over the years that there seems to be a lot of legacy code littered around the software, that I guess old school users probably still appreciate. But for the rest of us it leads to a lot of confusion! $\endgroup$ Commented Feb 7, 2023 at 5:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .