Just see for yourself: https://www.youtube.com/watch?v=TRonAc9TJv4 enter image description here

Im using most recent blender version(Ive tried with older versions too). With or without addons, this problem occurs.

Im using a laptop with windows 11, gpu intel Iris xe, Intel arc control. In my pc it works fine. I wonder if this is a bug or if Im doing something wrong, maybe its something related to my hardware. Any tips? Thank you!

enter image description here enter image description here

  • 3
    $\begingroup$ Hi. Do you have any questions? This is Q&A site run by volunteers, we are not programmers nor in any way associated with the Blender Foundation, decision making nor development process of the software. For bug reports please see Where to Report a Bug $\endgroup$ Feb 5 at 15:42

2 Answers 2


A lot of things can explain your issue here, but it comes down to two things: your hardware seems insufficient, and you are not being economic in how you use Blender.


As explained on Requirements — blender.org:

  • 64-bit quad core CPU with SSE2 support
  • 8 GB RAM
  • Full HD display
  • Mouse, trackpad or pen+tablet
  • Graphics card with 2 GB RAM, OpenGL 4.3
  • Less than 10 year old


Supported Graphics Cards



Haswell architecture and newer. [list of all Intel GPUs]

What you have:

An Intel i5 1135G7 CPU with an Iris Xe Graphics graphic chipset. No idea about your RAM memory though.

You seem to at least meet the minimal requirements to be able to run Blender, but not to make a lot of things with it. Not having a dedicated GPU means that a part of your RAM is used for graphics instead of being fully available to your CPU's function. It also is way less powerful than what a simple dedicated GPU could do.

Your CPU itself is probably to be considered a low-mid range, just looking at its median score of 62.72 on Blender Open Data. It's not a power horse.

If you are interested in changing your hardware, this isn't something we can really help with here. However, I encourage you to read this answer for a better understanding of the matter.

Using Blender

Deforming a character in realtime, even a simple one, can be a challenging task for a computer. And considering your hardware, I would be really carefull to not ask Blender to do too many things at the same time.
Yet looking at your screenshot, we can see that:

  • you have two viewports open at the same time

  • at least one of them is in material view, which is more complex to display than solid view

  • it's hard to see with the low resolution, but it looks like your viewport is also anti-aliased?
    You should probably go to Edit > Preferences > Viewport and disable these settings:

    viewport prefs

  • Do you use the Simplify panel in your rendering settings? simplify


The problem was solved by updating the gpu driver on device manager(uninstall the driver > install new downloaded driver). Actually this is a common issue for Iris xe users, as seen here: https://projects.blender.org/blender/blender/issues/86778

Thanks for the answers.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .