0
$\begingroup$

I am creating a model structure for Unity. However I cannot export anything that contains a second level of children without it's position rotation or even the hierarchy would not be messed up.

I want to create static model (so no fancy animations, or anything) which contains it's spare parts in a hierarchy. Lets say a chair, whit the sitting plane as the parent object, the legs and the back holding columns are children, and the back plane is child of the holding column.

So it is like this:

+ sitting plane
   + leg
   + leg
   + leg
   + leg
   + backPlaneHolder
      + empty1
   + backPlaneHolder
      + backPlane

When I export it to FBX, no matter how, either the position, rotation or the hierarchy will be messed up.

I really cant find a way to export my model... well... as it is, without messing it up.

What I already tried:

  • Exporting and reimporting it to blender, but even the imported model looks different.
  • I applied transform on them, so everything is in 0,0,0 rotation, 1,1,1 scale.
  • Also worth to mention that the hierarchy also contains two empty plain axes.
  • Normal Object parenting messing up the position and rotation of child's child.
  • Vertex parenting messing up the hierarchy, but keeps the position and rotation.

TLDR: I want to find a way to export a model which has a child which also has a child without either child's rotation/position or hierarchy would be messed up.

$\endgroup$
3
  • $\begingroup$ Maybe try clearing inverse parenting? $\endgroup$
    – TheLabCat
    Commented Feb 5, 2023 at 2:50
  • 1
    $\begingroup$ @TheLabCat Didn't help. Object (Without inverse), Object (Keep Transform without inverse) position and rotation are not correct In both cases. The empty and the backplane are in wrong position and rotation. the columns are right tho. (In the one that does not keep transfrom I had to manually set it in place before export, and it didn't kept anyting on the backplane...) $\endgroup$
    – Nova
    Commented Feb 5, 2023 at 22:53
  • 1
    $\begingroup$ Setting the origin would most likely solve the problem as everything will just be in the origin and that's it, but I can't do that, as the transform of the objects contains useful information. And it couldn't be done with the empties anyway.. $\endgroup$
    – Nova
    Commented Feb 5, 2023 at 23:03

1 Answer 1

0
$\begingroup$

I do not know why, but selecting "FBX units" solved the problem of wrong positions, Rotations however are not solved.

To me it seems that Empty axe objects are always have the wrong rotations for some reason when exported.

As a temporary workaround I solved it by rotating them 90° around the x axis, because they still get rotated -90° and in the end the rotation will be the one I wanted.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .