0
$\begingroup$

I'm really a newbie on blender, I barely know how to use the program and I'm watching a tutorial playlist to get started on this.

A problem came up.

When I use the "Material Preview" option, the default cube is completely black. When rendering with F12, too.

This happens using Engine Eevee and Cycles, but does not happen when using Workbench.

I really don't fully understand some solutions I found on the internet, but they don't seem to have anything to do with my problem.

I would really appreciate if someone could tell me what to do, since I barely know how to use the program and I can't even solve this. D:

As extra information:

OS: Linux, Debian 10.

Blender Version: 3.4.1

Processor: Intel Celeron N4020

$\endgroup$
3
  • $\begingroup$ Make sure that your graphics drivers are up to date. $\endgroup$ Feb 4, 2023 at 6:46
  • $\begingroup$ Does it happen with a new blend file at default setup? You can also try File > Defaults > Load Factory Settings. If still black could be graphic card as Christopher mentioned. If it is black only for specific blend file you can share file via blend-exchange.com ... BTW Workbench works just because the engine doesn't use scene lights. $\endgroup$
    – vklidu
    Feb 4, 2023 at 9:13
  • 1
    $\begingroup$ Hello please pack your images and share your file: blend-exchange.com $\endgroup$
    – moonboots
    Feb 4, 2023 at 9:39

2 Answers 2

1
$\begingroup$

I'm pretty new too, so I'm not super sure if this will work: If your scene light option is checked but you don't have any lights in, the cube wont be lit up. You can either uncheck scene lights and scene world (dropdown menu in the top right), or add lights :) Otherwise, it could just be a black material?

$\endgroup$
2
  • $\begingroup$ It could be possible, but the thing is, that the cube renders normally when using the Workbench render engine, so it's not a black material or missing lights. :( Also, maybe I'll try using the Steam Version, just to be sure if it happens there too. $\endgroup$ Feb 4, 2023 at 6:44
  • 1
    $\begingroup$ @MissingCiro .. the cube can render 'studio' normally in Workbench while having a black-evaluated material.. it depends on the settings. There's a lot of guesswork going on, here.. it would be good if you could share your file, as moonboots has suggested. $\endgroup$
    – Robin Betts
    Feb 4, 2023 at 11:02
1
$\begingroup$

You probably watched a video on texturing or something similar and created a new image texture which is black by default.

Material Preview has nothing to do with lighting your scene, rendered view does.

To fix this: Go to the Material Tab and try to change the base color back to RGB.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .