3
$\begingroup$

I often have the problem with custom fonts in Blender in that they end up looking really poor like this:

Enter image description here

I used a Google font here:

Enter image description here

I am working with a MacBook if that is important.

Do I have to consider any "special" font attribute that they work fine or am I making something really wrong here?

$\endgroup$
0

2 Answers 2

5
$\begingroup$

You have selected very poor made font. I case of J, it made by 2 shapes, overlapping each other:

enter image description here

Not only J, but look at e ant t:

enter image description here

And compare with good font, there no overlapping is allowed:

enter image description here

Good font makers will not allow themselves such sloppiness. It may be ok in 2D graphics, but not for 3D, where such things will lead to non-manifold geometry.

So better choose the right font.

$\endgroup$
4
  • $\begingroup$ might be...but this happens to every 2nd font on google....so are they all poor fonts? is there any "special" thing i can look upon, that the font is suitable? $\endgroup$
    – Chris
    Feb 3, 2023 at 12:47
  • $\begingroup$ Might be something related to dynamic weight, Or it just new kind of fonts made without care. All fonts that I usually use (Lato, Din, PT) have no such issues. $\endgroup$
    – Crantisz
    Feb 3, 2023 at 12:59
  • $\begingroup$ ok, thank you, i will try them as well $\endgroup$
    – Chris
    Feb 3, 2023 at 13:03
  • $\begingroup$ @Chris I usually don't have these issues either, but I never used any Google font so I cannot say anything about the quality of them - if they are generally a poor quality or not... $\endgroup$ Feb 3, 2023 at 13:08
1
$\begingroup$

From my post on a duplicate question:

Variable fonts, even when they come with static TTF files, seem especially prone to this issue because they're intentionally (and correctly!) designed with multiple overlapping elements and self intersections. Unfortunately, the static versions of these variable fonts may still retain those features, causing issues in Blender.

Some users report that OTF versions of TTF fonts may correctly flatten the shapes, but you can also fix files yourself with Font Forge.

Steps:

  1. Download Font Forge (free and open source)
  2. Open the font file you want to use in Blender
  3. Select all (Edit > Select > Select All)
  4. Remove overlap (Element > Overlap > Remove Overlap)
  5. Generate font (File > Generate Fonts…)

Screenshot of a TTF font opened Font Forge with the Edit, Select, Select All dropdown menu path highlighted

Second screenshot of Font Forge with the Element, Overlap, Remove Overlap dropdown menu path highlighted

Third screenshot of Font Forge with the File, Generate Fonts… dropdown menu path highlighted

I used the default TTF options when generating fonts. It takes all of 10 seconds to open a font file, process, and generate the patched file. Even easier if you macro the keyboard shortcuts (in MacOS that's command+a, command+shift+o, command+shift+g).

Many thanks to user chojnicki and their similar question/answer for pointing me in the right direction.

$\endgroup$
1
  • $\begingroup$ +1 thanks! good to know! $\endgroup$
    – Chris
    Feb 28 at 6:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .