I created a raiser model for IKEA Lack tables out of a basic cube. I've cut the cube in half and mirrored it to the bottom so I can edit 2 sites at once. When I export it I see errors in Cura. When I use the 3d print tool from blender and "check all" I receive many errors. These errors occured most likely by using the boolean modifier

Edit: Here is the file for further analysis

enter image description here

Cleaning up with "make manifolds" just removes almost the entire object and leaves me some faces.

enter image description here

When I activate mesh analysis, I see the bottom (mirrored site) with what I believe are intersections. I dont know how to get rid of this. I removed those red faces and recreated them with the same result.

enter image description here

In Cura my export looks like that:

enter image description here

Why does non-manifold edges highlight everywhere when I use loop cut's or extrusions? It seems unavoidable when I create a model. Even a basic Cube has at least one error with 3d-print tool.

enter image description here


1 Answer 1


I've had a look at your file, there's a couple issues. To make this model ready for printing here are some things you can do:

  • Find any overlapping polygons and remove them. You already found some, like the top and bottom plane but there are more. If you see any kind of flickering in your selection that means there is an overlapping polygon there. 1
  • Select all and use "Merge by Distance" (press M). This will merge any overlapping points.
  • Select all and use "Triangulate" (press ctrl + T). This will turn all your quads and n-gons into triangles. N-gons can create all sorts of issues so it's best to avoid them.
  • Select all and use "Limited Dissolve". (press X and select "Limited Dissolve"). Set the angle as low or as high as you like. This will simplify your mesh and remove any extra points. Be careful however, put the value too high and you will lose detail.

Now by exporting a new stl (export selection only) and importing it into Cura we already have a better result: enter image description here An improvement, but you can see that there are still some bits with funky colours. These are overlapping, inner and/or inverted polygons, so:

  • Search for any inner polygons and overlapping polygons and remove them. We can do this manually by checking all the polygons that Cura gave odd colours. If you select a polygon and hide it and there is still a polygon there, that's an overlapping polygon. Hide more polygons to find inner polygons and remove them, or move the view inside of the object and look for them that way.
  • After finding all extra polygons we can enable "Backface Culling" in "Viewport Shading" (top right of the viewport) to find the inverted polygons, because they become transparent. Flip the inverted polygons by selecting everything and reculculating the normals (press Shift + N).
  • Plug up any holes that remain, it seems there are issues for the screw holes in this model.

I know it might be frustrating but it'll take a bit of fiddling to fix it. I'm sure there are quicker automatic ways, sadly I'm not familiar with them. In my opinion it's best to prevent these issues from cropping up so that these types of fixes aren't necessary. You've mentioned that you've had issues with other models, can I ask more about your process?

I've put my attempt in the provided blend file. It looks like this in Cura, still some issues with the screw holes: 3


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .