I'm currently a beginner using Blender 3D, and I'm following a tutorial to get some experience with the software. I have a problem when doing Geometry Nodes on Blender. When I insert the Object Info node onto the Instance on Points node, the multiplied objects won't appear on the targeted mesh. I tried doing Ctrl+A, and Apply Scale, but nothing seemed to work. When I do it on the Icing layer, it just scales the mesh to an unreasonable amount. Is there any way I fix this problem?


This is the expectation I'm trying to follow, a.k.a, the tutorial: Belnder Donut Tutorial (Expectation)

And this is what I got: Reality

I'm currently using Blender 3.4.0, with Windows 10 Version 22H2. I hope these screenshots help!

With Regards...
  • $\begingroup$ Your Distribute Points on Faces node is not linked to anything so it can't distribute any points. Link your Group Input Geometry into its Mesh socket. $\endgroup$
    – Kuboå
    Feb 1 at 1:09
  • $\begingroup$ Okay, that worked, but I ran into another problem. I realized the scale was applied improperly from the target object. It took me time to realize that the bigger I scale the target object, the more properly the Instance scales by hitting Ctrl + A every time a scale is made. Is there a solution to this? Here's a screenshot of the problem: drive.google.com/file/d/1vVB4RV9n3uhLkojRg1LuyhghQiJfLhDC/… With Regards, $\endgroup$ Feb 17 at 1:20
  • $\begingroup$ Not sure what you mean, can you rephrase your question? What is the "target" object, the donut or the seed you're distributing? What are their scales? $\endgroup$
    – Kuboå
    Feb 17 at 5:51
  • $\begingroup$ Hi, I will start a new thread further explaining this problem. Thank you for your time and effort in helping me solve the last issue I dealt with! $\endgroup$ Mar 8 at 0:03
  • $\begingroup$ Here's the link in regards to the second question in more detail: blender.stackexchange.com/questions/287928/… $\endgroup$ Mar 8 at 0:12


You must log in to answer this question.

Browse other questions tagged .