0
$\begingroup$

I have a simple model with the top slide being the child. When I export this model into unity the parent transform is fine however the child transform has a negative rotation of 90 on the x axis.

export settings

basic model

blender base model transform

blender child model transform

unity child slide transform. -90 on x axis

$\endgroup$

1 Answer 1

1
$\begingroup$

Untick 'Use Space Transform' and use '-Y Forward' and 'Z Up' in Blender FBX export settings:

Blender Export Settings

If you are also exporting Armatures, set the Primary Bone Axis to -Y and Secondary Bone Axis to -X:
Blender Armature Export Settings

In Unity use the Bake Axis Conversion import setting:
Unity Import Settings

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .