0
$\begingroup$

I am using same HDRI, once for background and once for natural lights in my interior render: enter image description here

The problem is when looking trough glass material the HDRI is over exposed.

Result outside glass material: enter image description here

Looking through glass results in this: enter image description here

Is there a setting in the glass material that will improve this? My glass material: enter image description here

$\endgroup$

2 Answers 2

0
$\begingroup$

Try this for your world shader - the Is Camera Ray disables the (bright) look for the environment, but transparency shows the "true (bright) colors - the Is Glossy Ray on the second Mix Shader works to hide the bright image, even through glass:

BrightGlass

$\endgroup$
0
$\begingroup$

You have to combine the Is Camera Ray with the Is Transmission Ray from the Light Path node. You can do this with a Math node set to Maximum, since both outputs are either 0 or 1 you will always get 1 unless both outputs are 0. However, for realistic lighting it is absolutely correct that it is overexposed - inside a room you have to use a higher exposure in a real camera so that the room isn't too dark, and in this case the outside will be overexposed through the window.

mixing backgrounds

This doesn't change the overexposed look on the outside. But as I said, for realistic lighting it would be normal that you set a lower exposure for the outside and a higher exposure for the inside - and I don't mean the strength of the background shader, but the Exposure settings in either the Color Management or with an Exposure node in the Compositor for example.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .