0
$\begingroup$

I'm following the donut tutorial on YouTube and am struggling to add keyframes through the node editor like the author does.

Well, the keyframes appear to be added as I can see them when I switch to the 'Layout' view, but they are nowhere to be seen in 'Animation' view.

The animation also works when I hit the space bar.

I've also been sure make sure that my object is selected.

How do I view the keyframes in Animation mode?

enter image description here

Timeline in Animation view enter image description here

Timeline in Layout view enter image description here

$\endgroup$

1 Answer 1

0
$\begingroup$

In the Dope Sheet you have Only Show Selected enabled (the white arrow on blue button) which only shows you channels of selected objects and data.

In my example it shows keyframes on a cube which are animating the location, because the cube is selected:

only show selected

But there is something missing if you look at the Timeline, there are two more keyframes which don't show up in the Dope Sheet, this is because in the Timeline the option View > Only Keyframes from Selected Channels is disabled:

more keyframes visible

disabled selected channels

Those two extra keyframes are animating a shader node in the material of the cube - but the node is not selected. This is why it doesn't show up in the Dope Sheet that is set to only show channels of selected data. And in your screenshots it seems that the Set Position node is not selected, therefore it will not be shown in the Dope Sheet.

$\endgroup$
1
  • $\begingroup$ Amazing! Thank you $\endgroup$
    – user158694
    Jan 28, 2023 at 19:10

You must log in to answer this question.