Ambient occlusion not working in shading viewport / render.

I'm trying to render whats in GN_CONTAINER BOX with Ambient occlusion using the forest built in HDRI but it's not working. I believe I enabled all the options but I seem to be missing something.


See what I enabled below:







For back history: Scaling and centering generated objects to take up entire camera viewing width resolution using geometry nodes

Blend file below.


1 Answer 1


You're using a Scene > Unit Scale of $0.001$ so the default values are way off—1000 times smaller than usual. For Eevee, set the Ambient Occlusion > Distance value in Render Properties to $0.2$ or something higher and you should see the occlusion:

enter image description hereBe aware that in your setup the "Render Pass" mode in the shading options dropdown is set to "Ambient Occlusion"

Cycles doesn't have that option of course, and doesn't seem to respond well to this difference in scale. If you switch to the standard Combined render pass mode, you might notice it does have a little bit of AO, but very weak. That's due to the Ambient Occlusion node's default Distance value of $1.0$ in the shader. Multiply that with a bigger value as well and occlusion will pop up:

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .