7
$\begingroup$

I'm working with particles (for grass or leaves). The problem is the blend file is very huge when it contains a lot of particles.

Is it possible to stop blender storing particle data to make the file smaller?

$\endgroup$
  • 1
    $\begingroup$ While it isn't actually an answer to your question, you might save some space if you reduce the number of hairs and add Simple or Interpolated child hairs. Some quick experiments show that child hairs aren't free, but they are much cheaper than primary hairs. $\endgroup$ – Mutant Bob Apr 14 '15 at 21:12
4
$\begingroup$

One very simple way to do this is to write all the values for your particle systems that tell how many particles are to be rendered, and then to change that value to a much smaller one for storing.

Open a Text Editor region and type the particle system name and numbers:

enter image description here

You can now change back to these values when you want to use this file again.

I saved massive amounts of space. The original not reduced version was 15MB, while the reduced version was 550KB.

While this works, it can be quite tedious, and is still just a work around. MutantBob's answer might be more along the lines of what you are looking for.

$\endgroup$
  • $\begingroup$ Could be this option. Anyone knows if an addon can do that ? Like this one but it's not working on Blender 2.74. link $\endgroup$ – Cédric Apr 14 '15 at 21:08
4
$\begingroup$

In your particle system tab there is a minimized subsection called Cache. If you open that up and check the Disk Cache checkbox and Bake, that will cause your particle data to be stashed in a directory called blendcache_something/ and not in your .blend file.

$\endgroup$
  • 2
    $\begingroup$ thanks but that works only in emitter type and I'm using the hair type... $\endgroup$ – Cédric Apr 14 '15 at 21:03
  • 1
    $\begingroup$ Hmm, I guess that's because combing of hair is usually a critical part of the blender scene, and you really wouldn't want to lose the combing if there is any. $\endgroup$ – Mutant Bob Apr 14 '15 at 21:09
  • 1
    $\begingroup$ I'm just using hair type to make grass or leaves. So I'm not using combing. $\endgroup$ – Cédric Apr 14 '15 at 21:17
0
$\begingroup$

When you have a fluid simulation in your scene and you use objects with fluid type Particle, setting the fluid type to None also slashes the file size, in my case from 70MB to 1.5MB

This is a bit tedious, but your settings aren't lost. if you change the type to particle again, you will see your settings restored

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.