11
$\begingroup$

I am trying to make a smoke simulation which includes colored smoke. I have tried changing the smoke color in the domain of the simulation, but the color in rendered view mode doesn't change from the default. How can I change it?

Blend file: https://www.dropbox.com/s/1j4otu6dl6b7hnl/geyzer.blend?dl=0

$\endgroup$
4
  • $\begingroup$ change the colour in the colour bar... $\endgroup$
    – Scalia
    Apr 14 '15 at 14:25
  • 1
    $\begingroup$ related: blender.stackexchange.com/questions/19474/… $\endgroup$
    – p2or
    Apr 14 '15 at 15:42
  • 1
    $\begingroup$ Cycles or Blender Internal render engines? This is important, as the approach is extremely different between the two! $\endgroup$
    – VRM
    Apr 14 '15 at 21:37
  • $\begingroup$ I use Cycles engine $\endgroup$
    – Tal
    Apr 15 '15 at 11:12
7
$\begingroup$

Select the smoke flow object and in the physics tab, click the option that says "Smoke Colour" a colour wheel will appear. Using the colour wheel and the lighten darken option to its right, pick your desired colour. Things I did:

  • added a white plane behind the simulation; it's easier to see.

  • moved the camera to a better angle

  • changed the smoke colour in the smoke flow object, not the domain.

$\endgroup$
5
  • $\begingroup$ yes i tried that and it didn't work... $\endgroup$
    – Tal
    Apr 14 '15 at 15:43
  • $\begingroup$ Do tell why, I'm curious now, may you post a .blend file? $\endgroup$
    – Scalia
    Apr 14 '15 at 19:37
  • $\begingroup$ yea no problem, here: dropbox.com/s/1j4otu6dl6b7hnl/geyzer.blend?dl=0 $\endgroup$
    – Tal
    Apr 15 '15 at 11:05
  • $\begingroup$ I don't see the problem. $\endgroup$
    – Scalia
    Apr 15 '15 at 20:10
  • $\begingroup$ I'm having the same problem on Blender 2.83.0. I changed the "Smoke Color" attribute of the "Flow" object, and it's not actually changing. I changed the renderer to "Workbench" and that is the only way I could get my smoke color to be honored. $\endgroup$ Jun 14 '20 at 15:53
2
$\begingroup$

Even if this is an old question by now, it could help others.

Anyways, I'm using Blender 2.80 right now and had this same exact issue, I tried the currently existing answers in this thread, however, none of them worked. Then, when watching this slightly outdated smoke tutorial, I saw that he had selected the smoke domain and then proceeded to edit its node setup. I figured I would do the same even though it seems the node setup for smoke has changed from 2.79 to 2.80.

There were two nodes here, one Material Output node and one Principled Volume node.

Node setup for the smoke simulation domain. Blender 2.80

I noticed that the Principled Volume node had a color setting, which was set to be a light grey color. Mind you I had set the smoke color to be red in the flow object of the simulation.

This color setting seemed promising so I clicked it, changed the color from the light grey into a redder color. I then checked the viewport. It had changed, the color of the smoke had actually changed. I had figured it out. I was ecstatic, and suddenly I thought of this thread and thought I would share my findings to help others who might run into this issue.

I do hope this help anyone who might be struggling with the same issue.

$\endgroup$
1
$\begingroup$

Blender 2.9:

In the Outliner (scene hierarchy):

  1. Select your smoke Emitter object
  2. Click the little triangle to expand
  3. Do the same with the Modifiers section that appears beneath it
  4. Within Modifiers, select Fluid
  5. Smoke Colour is automatically selected... if not, click Physics tab in the Inspector
  6. click on the colour bar to alter it.

If the Smoke Colour section is not available, try clicking the Shading tab at the top of the screen and repeating the process.

$\endgroup$
0
$\begingroup$

To change the smoke colour simply select the smoke domain box in object mode and select the base object, for example a cube, then move over to the physics tab, the flow option under the smoke heading should be automatically selected from there all you do is navigate to the smoke colour option and there you can change the colour.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.