0
$\begingroup$

I'm experiencing an issue with the lights in my scene. I'm attempting to make a lit up chess board with glass pieces. Everything looks alright in the viewport with the pieces completely lit up.

enter image description here

However, when I try to render an image there's a clear line at the top of the image (around file A) where the light ends abruptly.

enter image description here

I'm currently using cycles with 4096 samples and I've increased the max bounces under light paths. I've tried multiple camera angles and a similar issue appears in all of them. The scale of the objects is close to real life size. I've also tried adjusting the size and strength of the lights but it only seems to make a difference to the lights closer to the camera.

Render from another angle.

enter image description here

Thank you for your time and assistance!

$\endgroup$
1
  • $\begingroup$ Since it seems to be an issue of tower and not spawn figure - ry to render without checkerboard it can be an optical thing (but is should be in preview too) ... or disable Denoise from render if make any difference ... usually it can be Light path issue, but since there is not a different setup for Viewport/Rendrer it is doesn't seem to be the case too. $\endgroup$
    – vklidu
    Jan 25, 2023 at 20:31

1 Answer 1

0
$\begingroup$

As vklidu suggested I turned off the board and the lights on the pieces seemed to render properly. I was able to get a passable result by rendering the board, table, and lights on one view layer and just the pieces and lights on another view layer.

enter image description here

$\endgroup$
1
  • $\begingroup$ Great you found a way, but lights doesn't look the same (especially at bottom of figures) and doesn't explains the issue. If you are OK with that - fine. If you want to know is going on share your blend blend-exchange.com $\endgroup$
    – vklidu
    Jan 26, 2023 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .