2
$\begingroup$

I'm simply trying to make a closeup of sand in this shot. Using a collection in place of hair in the particle system in Blender, I thought I could create some realistic sand shots. However, I keep finding these square gaps. After some looking around I found most of these particles are under the mesh in these square patches. I know it's only present in the ridges of the plane mesh but I want to know how to get rid of these gaps.enter image description here

For the blender file: https://drive.google.com/file/d/1t7WemNmoYHceRCbi9tm1yQ7-V1ntYcEv/view?usp=sharing

Another similar blender project where the plane is using an addon for its shape: https://drive.google.com/file/d/1GejuC9UQy1L6nLho8UPKLNrbxIhKXNhL/view?usp=sharing You can see the different gaps here.

$\endgroup$
6
  • $\begingroup$ Is it possible that your normals are flipped? Turn on 'Face Orientation' (F3 -> Search for Face Orientation) and then see if you have red and blue patches correlating with the hair. If so, do a "recalculate outside" operation to get all of your normals facing the same direction. Depending on how your mesh was made, you may also need to turn on "Use Modifier Stack" in the hair particle settings. $\endgroup$
    – Black Fox
    Jan 24, 2023 at 7:32
  • $\begingroup$ That's weird but maybe try to switch to Weight Paint mode and in the Weights panel > Smooth and in the Operator box give it several iterations? $\endgroup$
    – moonboots
    Jan 24, 2023 at 7:41
  • $\begingroup$ @BlackFox Just a quick question: how do you find Face Orientation with F3? It shows only tools and operations in my Blender, not the Overlays. $\endgroup$ Jan 24, 2023 at 8:34
  • $\begingroup$ Okay, this is strange. It seems that for some faces the sand is only placed along the edges, although the normals are oriented correctly and there are no duplicates or whatever. Deleting one of those faces and then filling it with F makes the sand appear there. Switching to Weight Paint mode shows everything correctly - and there all faces have sand. The problem occurs only in Object Mode. I think I had something like that before and just rebuilt the mesh, but I would like to know a solution for this problem, too. $\endgroup$ Jan 24, 2023 at 9:03
  • $\begingroup$ @GordonBrinkmann It may not be in there, I’m not able to access my computer at the moment. You may also just need to be in edit mode when you do the search, sorry I can’t verify. Another possible problem, have you changed versions since you started the file? I had a particle system break between one Alpha build and another just one month apart. $\endgroup$
    – Black Fox
    Jan 25, 2023 at 9:04

1 Answer 1

1
$\begingroup$

At first I thought there is something wrong with your file or your particle system. But I recreated it from scratch with my own plane and an icosphere as instance object and got the same result:

particle distribution inconsistent

I switched from rendering Object to Path and found the hair looked normal... but when I looked at the plane from below, some hairs were a bit more sticking out than others - and also clearly in patterns related to the faces. It's just not so obvious from above because the hair is so long.

hair displaced

Going back to Object I saw this was true for the icospheres as well - in parts where they were missing on the top side, they were visible from below. So I wondered what is wrong with those faces and the simple answer is, by displacing them they became non-planar and that makes the particles spawn below the surface if the deformation is too strong.

The solution, I selected all faces. Not just the ones in the group, since particles are getting spawned on adjacent faces to the group vertices too - but it would have been sufficient to select the group vertices and expand the selection by Ctrl+Numpad +. From the Mesh menu I then chose Clean Up > Split Non-Planar Faces.

split non-planar faces

I found that a Max Angle of 5° seemed to be sufficient for the most part, but to be on the safe side you can set it much lower. Of course you could simply split all of them, but maybe you want to generate as few polygons as possible.

max angle setting

After I did this, the particles showed up everywhere and none of them were placed below the surface. In general I think if you simply had a higher resolution on the mesh the effect would be much less visible, but the larger the faces and the higher the angle of deformation, the more obvious it becomes. Without splitting the faces, scaling the object down on the Z axis to flatten it would have helped for distributing the particles, but of course then the landscape would be too flat ;)

particles correctly distributed

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .