0
$\begingroup$

I'm following the earth tutorial by Andrew Price.

I'm rendering one single image that is now taking 33 min, and it's only at 9% rendering...
He rendered one image in 14 seconds.

My graphics card: NVIDIA GeForce RTX 3060 which I also ticked in "Preferences" with CUDA. In the render settings, I chose GPU Compute (rendering with Cycles). I'm aware he's using a better GPU, but still, I figured RTX 3060 should be strong enough to render this scene. I have already tried with OptiX, but there's no difference.

By changing the Feature Set from "Experimental" to "Supported" it does render a bit faster. Experimental is chosen in the tutorial to enable Adaptive Subdivision (which I thought should actually speed up render time and not slow it down).

Thank you in advance

enter image description here

enter image description here

$\endgroup$
6
  • $\begingroup$ Hello, could you edit your question with a screenshot of your render settings? $\endgroup$ Commented Jan 23, 2023 at 13:47
  • 1
    $\begingroup$ Actually Adaptive Subdivision is not making it faster. It is creating displacement (but based on pixel resolution instead of geometry, to put it simple) which has to be computed. If you have displacment on your model relying on Adaptive Subdivision and you switch to Supported, then this feature and the displacement is gone, so there's less to compute which makes the render faster. Would you mind showing the other render settings under Sampling as well, like Noise Threshold, Max Samples etc.? $\endgroup$ Commented Jan 23, 2023 at 14:53
  • $\begingroup$ I have updated the post, thank you! $\endgroup$
    – FranziskaG
    Commented Jan 23, 2023 at 15:17
  • $\begingroup$ In addition to Gordon's comment, in the provided screenshot you're using CUDA rendering instead of OptiX, and having both the GPU and CPU selected means you're using Hybrid Rendering, which may or may not be slower. $\endgroup$ Commented Jan 23, 2023 at 15:48
  • $\begingroup$ I think that just solved the issue. I removed the CPU and switched to OptiX. I thought CUDA was the way to go, thank you so much! $\endgroup$
    – FranziskaG
    Commented Jan 23, 2023 at 17:07

2 Answers 2

1
$\begingroup$

There're 2 problems of your Cycles rendering devices:

  1. In most of cases, don't enable CPU in Cycles rendering devices
  2. Use OptiX for NVIDIA GeForce 20/30 series because 20/30 series supports hardware ray tracing. This will accelerate rendering process a lot.

And you should check your render settings. 4096 sampling is not necessary unless there's massive noise when rendering. So you have to set high sampling numbers to save details when denoising.

$\endgroup$
1
  • $\begingroup$ "In most of cases, don't enable CPU in Cycles rendering devices" Why and do you have data on this? $\endgroup$
    – Lauloque
    Commented Aug 22, 2023 at 17:11
1
$\begingroup$

I have seen some problems in your settings. First of all a laptop rtx 3060 is quite slow compared to desktop counter part, and in case of Andrew Price, he uses four 3090s in NVlink. Next you using hybrid rendering which in most cases slows down the render time. Also use optix instead of cuda with only gpu selected. Also use denoiser with optix (not openimagedenoiser) in which case u can higher the noise threshold to 0.2 or something and get a good result. Bonus, you can check in camera settings render only selected

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .