2
$\begingroup$

I'm trying to emit particles from this face, with the particles spread evenly/randomly across it... however, because the faces are spread across it horizontally, the particles are not covering it how I would like. They're mostly clumping up where there are higher concentrations of vertices.

I'm guessing the solution would be to subdivide it in a way that there are more vertical cuts, resulting in more square faces, or more vertices spread evenly throughout the surface.

But when I try and simply subdivide I only end up with more horizontal faces. And the knife tool is way too tedious to achieve the level of detail I need.

How can I pull this off?

Project file

Enter image description here

Enter image description here

Enter image description here

$\endgroup$

2 Answers 2

4
$\begingroup$

I don't imagine you need to edit your mesh for this. Just ticking the Even Distribution option of your Particle System under the Emission > Source panel should do. The old particle system is pretty finicky so you might need to enable and disable it a few times, undo/redo, or reset the timeline to see it, but it does work:

enter image description here

At the end there, I'm selecting everything, then X (Delete menu) > Limited Dissolve to get rid of most edges without affecting the outline. That can also be a help in situations like these if you don't want to bother with remeshing.

$\endgroup$
1
  • $\begingroup$ Oh man I'm glad you mentioned forcing the particle system to update because I was banging my head against the wall wondering why Even Distribution wasn't working. Per your answer I just cycled the number of particles and viola! everything magically jumped into place. Thank you! $\endgroup$ Jan 22, 2023 at 23:03
3
$\begingroup$

To start, I disabled the particles from preview so you can see the mesh better. Use a Decimate Modifier set to Planar to remove all the "junky" topology. Apply the modifier:

Dec1

Then select the whole mesh and extrude (E) it "upwards" on the Z-Axis. This is necessary for the next step to work:

Dec2

Add a Remesh Modifier set to "Sharp" with octree depth of 8 or so.

Dec3

Select one face on the "top" of the mesh then pick Select > Select Similar > Normal from the menu at top:

Dec4

Then pick Select > Invert from the top to select all the faces not on the "top" of the mesh.

Dec5

Delete those faces:

Dec6

Move the mesh back "down" on the Z-Axis (if necessary):

Dec7

Unhide the particles:

Dec8

$\endgroup$
4
  • $\begingroup$ I just noticed, however, that the particles go a bit wonky after this. You will probably need to re-do your particle system (delete and re-add the modifier ) , and possibly apply rotation and scale to your object as well. $\endgroup$ Jan 22, 2023 at 21:36
  • $\begingroup$ Hey man thank you for this. @Kuboa's solution actually solved my problem without needing to do this, but I'm super glad I asked and grateful for this explanation. This is literally a technique I knew nothing about, and it will come in handy a lot in the future (and in the past had I only known!). Cheers $\endgroup$ Jan 22, 2023 at 23:01
  • $\begingroup$ @GlenCandle Yeah - I thought you wanted the mesh subdivided in addition to the particles "just working" - at least you can use the example if/when you need to clean up dirty topology in the future (I'm guessing that mesh came from an SVG - they always need cleaning). $\endgroup$ Jan 23, 2023 at 5:16
  • $\begingroup$ Ha, yeah, SVG. I had to clean up the control points, but I never knew a good way to clean up all the faces after converting to mesh. And I always wondered what the Remesh Modifier was good for. Now I know! Thanks again. $\endgroup$ Jan 23, 2023 at 17:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .