12
$\begingroup$

I'm still learning to model on Blender, but one thing I can't grasp is how to make such perfectly aligned and evenly-spaced mesh topologies. I'm trying to model an acoustic guitar and my mesh looks at best messy:guitar topology image

How can I create a smooth topology like this one?smooth instrument topology Notice how the features in the instrument's face align perfectly with its outline.

$\endgroup$
7
$\begingroup$

You can do that easily with edge loops.

Option 1

Start with a circle.

Extrude it (Press E and Scale it S).

Take the outermost vertices and grab them (G) create the shape of the guitar.

enter image description here

Until you have the full outline of your guitar.

enter image description here

Create edge loops by pressing CtrlR. And dragging the mouse to the middle of the geometry. You can choose how many edge loops you want to create.

enter image description here

Keep adding edge loops to refine your shape.

enter image description here

Option 2

Another way to do this is modeling with curves:

Add a Curve_Circle object.

In edit mode subdivide it and add an outer circle. Subdivide it and shape it to the form you need. (It's very important that your circles have the same number of control points, 8 in this example).

enter image description here

Make sure the fill option in your curve is set to none:

enter image description here

Exit edit mode and convert your curve to mesh by pressing AltC and select Mesh form Curve/Meta.

Then in edit mode select all your vertices and do bridge edge loops (press the Space Bar and type Bridge...)

Then you can do edge loop cuts with CTRLR

Note the adjustments you can do changing the factor

enter image description here

$\endgroup$
  • $\begingroup$ I'd like to have that 'polygonal' look in the example picture. If it's not possible easily, however, I can accept this. Let me just try it later. $\endgroup$ – Délisson Junio Apr 13 '15 at 20:56
4
$\begingroup$

I find this easiest to do with Proportional Editing. Hit O to enable this handy feature that allows you to move nearby vertices slightly based on a curve while you squiggle the vertex that you want as your guide around. While "squiggling", you may choose to either grow or shrink the effect area by scrolling the mouse-wheel up or down respectively. Not quite the effect you were looking for? try changing the curve shape using the pop up found near the proportional editing button (a small blue circle, don't ask why).

Remember though, always before editing, try to get as much of the basic shape down with modifiers. One of the best for your particular musical case is the Lattice Deform mod. Basically, you make a "container" for your mesh and set it as the target for the modifier, now, if you edit the lattice, the mesh will squish along like it was made of baked mustard.Bevel mods, Subsurfs with "optimize display" enabled and remesh mods can also help make quick work of would-be sloppy geometry. Any sharp edges should be bevelled, and N-gons should be avoided at any-cost, even if it takes hours of sitting there selecting vertices and hitting J.

$\endgroup$
  • 3
    $\begingroup$ don't you love sales pitch answers? $\endgroup$ – Scalia Apr 13 '15 at 4:57
  • $\begingroup$ Sometimes it just seems impossible to avoid those evil n-gons for me ): $\endgroup$ – Délisson Junio Apr 13 '15 at 21:00
  • $\begingroup$ Not quite impossible, just time consuming... $\endgroup$ – Scalia Apr 13 '15 at 23:06
  • $\begingroup$ @cegaton they aren't -_- $\endgroup$ – Scalia Mar 14 '18 at 4:18
3
$\begingroup$

Other useful tool is the Grid Fill tool.

If you have the outline of your object. You can use the fill tool to connect the vertices. Moving the span value will allow you get to the proper topology.

enter image description here

NOTE: For this to work you need a continuous loop with an Even number of vertices. An Odd number of vertices will report a "must select two edge loops" error.

$\endgroup$
  • 2
    $\begingroup$ When I select my outline, grid fill tells me that I must select two edge loops. Then I insert the middle circle and it says they must have equal vertex count. This seems rather awkward, but finally when i make them the same count, blender tells me it doesn't support inner closed loops. I must be doing this really wrong. $\endgroup$ – Délisson Junio Apr 13 '15 at 9:14
  • $\begingroup$ @Cegaton this is a really cool tool that ive not seen, but i don't think it solves his prob. $\endgroup$ – Scalia Apr 13 '15 at 15:32
2
$\begingroup$

From your question I see that you kept calling it smooth and align perfectly with its outline,so the answer for this is as following. There is an option in the subsurface modifier Show on cage so for example I have this object here with this topology: enter image description here

And I enable The show in cage option: enter image description here

Now it become smooth and fit to the model enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.