1
$\begingroup$

I am trying to render a transparent PNG for a website with a dark background.

When I render the image with the transparent film in Cycles, it produces a lot of noise at the edges of the gradient (shown on a black for clarity)

enter image description here

The material is a Principled BSDF shader with emission and alpha falloff controlled by ColoRamp:

enter image description here

The issue is in the alpha channel. You can see it clearly if you switch to alpha channel in render window, and toggle between Evee and Cycles render slots. Evee's alpha does not have this pixelation effect:

enter image description here

I tried bumping the sample count to 300, but that did not fix the problem

Here is the scene blend file:

$\endgroup$

1 Answer 1

0
$\begingroup$

Your assumption of the samples being the issue is correct. And when you have too much noise, the two main tools for you is to either play with render settings like samples to get a cleaner result but often at the cost of longer render times or cutout global illumination, or use a denoiser.

As of today, the only way to denoise a specific channel or pass is via the compositor:

compositing setup

Add a Denoise node, plug your Render Layer's alpha socket to the Denoise's Image socket. I find the result slightly better in Fast mode and with the Render Layer's Noisy Image plugged into the Denoise's Albedo. Then plug the Denoise's Image socket to your Composite's Alpha.

$\endgroup$
1
  • $\begingroup$ I bumped the samples to 500 and with your compositor setup the noise is practically gone! Thank you! $\endgroup$
    – Mike Nov
    Jan 21, 2023 at 9:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .