0
$\begingroup$

I've rendered an animation using .exr multilayer.(Overnight on batch file, files look Ok.)

Please correct me if I'm wrong, but should I be able to re-import the files and still use the Mist Pass etc? once rendered and re-imported ?

I'm not sure what I've done / am doing wrong, but when I re-import using ADD-Image sequence or any of the other options, the "Mist Pass" doesn't show up as an available output in the node.

(I Was going to post last night, but thought I'd render some out normally, straight from Blender. I did, with the same result.)

I'm confused. Does anyone have a clue what I'm doing wrong? I'm sure I've done this before with no issue.

Many thanks

EDIT

I've been looking through many sites since, and In earlier versions of Blender you needed to put a "File Output" and then add the relevant nodes. Mine doesn't seem to have the "Output Node" so maybe I need to re-render with this node set-up properly ? I'm new to compositing layers Blender, and what I found was from Blender 2.83 or similar is this still the way to go ? Many thanks

Running Blender 3.4 currently.

$\endgroup$

1 Answer 1

0
$\begingroup$

To make sure this works do the following:

  1. Enable the Mist pass under View Layer Properties > Data > Passes (of course).

enable mist pass

  1. In the Compositor, add a File Output node with Shift+A > Add > Output > File Output. Go to the Node properties in the sidepanel (press N to bring it up if it's not there), set it to File Type > OpenEXR Multilayer. Add a second input by clicking the Add Input button.

add file output

  1. You can rename the layer to something helpful like "Mist" for example. Plug the Image output of the Render Layers node in the first socket of the File Output node and the Mist output into the second. Now you can press F12 to render. This automatically saves a file "0001.exr" (with "1" being the current frame number, like when rendering animations) in the folder specified under Path.

connect output passes

  1. Now you can simply import the EXR file into the Compositor with Shift+A > Add > Input > Image and open it. The Image node then comes with two outputs, "Mist" and "Image" which were saved earlier. (Honestly, why it shows the "Mist" layer as first although it was saved as second layer I have no idea.) If you plug the "Mist" output into a Viewer Node you see that it contains the Mist pass.

imported image

Of course this works with other output passes as well.

$\endgroup$
2
  • $\begingroup$ Thankyou, I've already wasted 2 nights, (playing with settings, .exr & multilayer .exr etc) but the info you gave me, made it worth it in the end, glad I joined the Forum, many thanks for your time and effort on this to make it so clear for me and any others. $\endgroup$
    – John Fearn
    Commented Jan 21, 2023 at 20:10
  • $\begingroup$ @JohnFearn You're welcome. If this answer helped you, you might consider accepting it. $\endgroup$ Commented Jan 21, 2023 at 23:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .