5
$\begingroup$

I've assigned material with textures and it displays properly in viewport, however, material preview still doesn't show my texture:

No material preview

Same thing in Material tab, the texture doesn't show, it's only a white sphere. Am i missing something? BTW. Why to assign material, we must enter the Edit mode? It's problematic when assigning material to many different objects. Or maybe again i'm missing something here? :)

Blender file:

$\endgroup$
  • $\begingroup$ Could you post a .blend file, using a service like Blend-Exchange, or add more screen shot of all your material and texture settings/nodes? There are many things that could be causing this and more details would be very helpful $\endgroup$ – GiantCowFilms Apr 11 '15 at 13:05
  • $\begingroup$ I've posted my .blend file (updated the question). I'm just trying to do basic material things, like assign textures with normal maps, specular maps, etc. I'm new to this, so maybe there is a little checkbox that i need to enable, or something like that... $\endgroup$ – Good Samaritan Apr 11 '15 at 14:37
  • 2
    $\begingroup$ BTW, you should have packed the texture in with the .blend file... $\endgroup$ – GiantCowFilms Apr 11 '15 at 14:52
  • $\begingroup$ Strange, when i open this blend file the texture is already there and displays on the mesh... | Edit: OK, i've downloaded it and this file doesn't have texture, which is strange, because the exact copy of it (in my folder) has textures in its file. I don't know what's going on here, i'll try fix it asap $\endgroup$ – Good Samaritan Apr 11 '15 at 14:56
  • $\begingroup$ OK, i've selected checkbox "pack the image" next to the texture, now it should be inside the file. I've updated my question with new blend file. $\endgroup$ – Good Samaritan Apr 11 '15 at 15:01
4
$\begingroup$

The texture is setup correctly, but you have mirror enabled with reflectivity set to 1. This means that the material is entirely reflecting the environment around it, but as the mirror color is black, no light is actually reflected.

If you disable mirror, the texture is visible:

enter image description here

Note that I also set the specular intensity to 0, otherwise the texture is a little difficult to see (but visible).

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.