2
$\begingroup$

I don't know why this is happening. I'm following online courses for 3ds Max, but all the faces look wonky. So I exported the piece to Blender, but when I clicked Shade Flat, all the faces shine each way and all is messed up.

enter image description here

Anyway, the piece doesn't have any doubles I guess, and here is the blender file

Please, have a look and tell me what's the problem.

$\endgroup$
0

2 Answers 2

4
$\begingroup$

You can untick Auto Smooth and this will get rid of the strange shading in flat shading mode.

However, if for some reason you want to shade it smooth afterwards (perhaps because you added beveled edges or some round parts to it) and maybe also need Auto Smooth, you'll run into problems again.

The real reason for this odd shading is that there are custom split normals on the object. To remove them, go a little below the Normals > Auto Smooth option:

Under Object Data Properties > Geometry Data, click on Clear Custom Split Normals Data and the shading is correct again. Those custom split normals are sometimes created by modifiers etc.

Before: before clearing custom split normals

After: after clearing split normals

$\endgroup$
2
  • 1
    $\begingroup$ @HarryMcKenzie For the purpose, read the section Custom Split Normals in the Blender manual's chapter about Editing > Normals. Usually I would have marked it as duplicate since this topic already came up here a few times. No matter the purpose, the reason these split normals are sometimes on meshes although you don't want them is either you created them by accident or you have an FBX model with split normals imported from somewhere, CAD software tends to create them for example. $\endgroup$ Jan 12, 2023 at 7:41
  • $\begingroup$ @HarryMcKenzie For the text inside images: I think Duarte mostly doesn't like it when text in images holds information and you cannot find it if you were viewing this text-only (or use text-to-speech if you are visually impaired), but I guess my answer holds all relevant information in the text and the images are just for visualization. $\endgroup$ Jan 12, 2023 at 7:55
2
$\begingroup$

Untick Auto Smooth checkbox located under Object Data Properties > Normals > Auto Smooth

enter image description here

$\endgroup$
2
  • $\begingroup$ This only treats the symptoms, not the cause. $\endgroup$ Jan 12, 2023 at 7:24
  • $\begingroup$ @GordonBrinkmann ah thanks for your feedback and new answer post. we learn something everyday :D $\endgroup$ Jan 12, 2023 at 7:29

Not the answer you're looking for? Browse other questions tagged .