2
$\begingroup$

If you save and close a Blender file with the shading mode set to Material Preview, once you reopen the file the shading mode is still set this way. In the case of complex scenes with lots of materials and textures, this can potentially lead to a freeze of the entire interface for several minutes while Blender computes all the shaders.

There is a (paid) addon to avoid this, Open Solid. Is there a way to do this manually, eg. using a command in the terminal?

$\endgroup$

2 Answers 2

5
$\begingroup$

Rather than changing it in Preferences, you can use File>Open within Blender, then either press N or click the top-right Settings gear icon to bring up the Settings Panel. Then uncheck Load UI and load your file as usual. That will load the file into your default saved Blender view ignoring any UI settings in the loaded file.

enter image description here

$\endgroup$
3
$\begingroup$

It's currently not possible but there is a feature request open here Always open file in Solid mode. Fortunately there is still a workaround. Under menu Edit > Preferences > Save & Load, temporarily untick the Load UI setting and then open your file. Then tick it back on.

enter image description here

$\endgroup$
2
  • 2
    $\begingroup$ If you reopen the file from a running instance of Blender you can do that from the 'N' panel of the file selector without having to go to preferences. $\endgroup$
    – John Eason
    Commented Jan 11, 2023 at 14:31
  • $\begingroup$ ah nice, thats good to know, can u post an answer coz im not really sure how exactly it works $\endgroup$
    – Harry McKenzie
    Commented Jan 11, 2023 at 14:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .