0
$\begingroup$

I was following this tutorial https://www.youtube.com/watch?v=7KzhNYyp63A&list=PLZpDYt0cyiusDdsgdb9FgfT7onV7th8mJ&index=11

In order to make a model that shaded in a similar manner however for some reason even when I follow the steps rather than immediately changing the normals like it does in the video Nothing happens no matter what mesh or object I set as the source enter image description here

Blend file

$\endgroup$

1 Answer 1

0
$\begingroup$

There are multiple issues in your file.

To the right of your Source (Cube.001) in your Data Transfer modifier, there's a little button that looks like three arrows. The tooltip for this reads something like, "Evaluate source and destination meshes in global space." By default, this should be enabled; on your image, it is not. If this is not enabled, moving the source mesh around in object mode will do nothing.

Additionally, you're modulating your data transfer by "Face Section" vertex group, but no vertices are assigned to this vertex group.

Finally, you have a subdivision modifier, which by default recalculates your normals. If you'd like this modifier to interpolate existing custom normals instead, enable "Use custom normals" in that modifier's Advanced section.

This is what you're supposed to do-- however, it looks like there's a bug where Blender is failing to create the necessary dependency on the source object. Save and reloading at this point should fix it; adding a subdivision modifier to the source mesh and then deleting that subdivision modifier seems to get Blender to recalculate the dependencies properly.

This will get it working. However, you should be aware that your normals on your source object appear to be backwards. You should probably flip those normals.

$\endgroup$
3
  • $\begingroup$ Nope doesn't fix the issue. I turned that off while I was trying to fix it myself, thought I turned it back on. and the download works for me so I am not sure what the issue is. $\endgroup$
    – A guest
    Commented Jan 10, 2023 at 18:52
  • $\begingroup$ Downloaded .blend, see edits. $\endgroup$
    – Nathan
    Commented Jan 10, 2023 at 20:11
  • $\begingroup$ I see My issue was that I assigned (Hit the button assign) While the strength was at zero so it would select the vertices and I assumed that meant they were fully assigned. Changing it to one made it work after I did what you said to update the dependancies to my memory I tried changing it to one and it still didn't respond but perhaps I was mistaken. $\endgroup$
    – A guest
    Commented Jan 11, 2023 at 3:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .