1
$\begingroup$

I'm a noob in blender and I've encountered this before but don't remember how i fixed it. The fluid shows these multicolor heatmap like surface in viewport.

fluid multicolor

Renders the domain as a cube instead.

rendered domain

I would really appreciate it if it's explained what it is, why it happens and a way to turn it off. I'm using Blender 3.0.

I've googled a lot, found these tips and tried:

1 Turning off "Liquid" option in domain but that makes the entire thing disappear

2 In one forum said to turn off "velocity" under domain but can't find the option

3 Turned off "realtime" and "render" button in Particles tab but it makes the entire thing disappear again

4 Setting any option from "Rendered as" or "Viewport Display" in Particles tab doesn't fix it Setting Viewport display as "Material" or "None" enabled Mesh and turned off Camera in Particles tab

Here's the blend file :

$\endgroup$
3
  • 2
    $\begingroup$ Under Fluid Properties you have to enable Mesh, to disable particles you can go to Modifier or Particle System tab and disable it by click on icon (monitor/camera). $\endgroup$
    – vklidu
    Commented Jan 8, 2023 at 18:15
  • $\begingroup$ It renders fine in blender v3.4. I'll install 3.0 and have a looksee. How did this "Material.001" get set up -- automatically by the menu "Object >> Quick Effects >> Liquid"? It has no Volume output connection and seems rather primitive. With a new blender file/session try out the Quick effects and use a material similar to what it creates ("Liquid Domain Material"), in this blend file also. You may have to adjust/increase the Density in the "Volume Absorption" node that it creates for you, and lower the IOR in the "Glass BSDF". Added v3.4 screenshot to my answer. $\endgroup$
    – james_t
    Commented Jan 11, 2023 at 16:38
  • $\begingroup$ Good rendering results (not a red cube) with version 3.0 also. Did you "Free All" (Domain cache) and then Bake All? $\endgroup$
    – james_t
    Commented Jan 11, 2023 at 16:52

2 Answers 2

1
$\begingroup$

The Domain system for fluid gets created (quick effects) with both a Fluid Domain and a Particle System. You'll find both in the Modifiers panel:

enter image description here

enter image description here

In the Particle System, the default is Velocity coloring, which you can change to None or Material (instead of Velocity or Acceleration):

enter image description here

What I see if I use your blend file in version 3.4. Also in 3.0. I was sure to Free All and then Bake All in the Domain Cache:

enter image description here

If for some reason you want to cause other viewing problems :-) (like having a solid block displayed when you free the cache!), you can set the domain's viewport display to Textured, and set the 3DView to "Material Preview" or "Render" modes enter image description here

I recommend against doing these display modes; just be patient and do some test renders or switching these back again (wire and Solid Display mode) after you've worked on the material.

$\endgroup$
7
  • $\begingroup$ Setting it to Material or None turns the surface white and still renders as a red cube. I added the image. $\endgroup$
    – 0cybonysc
    Commented Jan 8, 2023 at 17:27
  • 1
    $\begingroup$ @0cybonysc -- that is a separate question: rendering vs. viewport. If you search for liquid render or look at blender.stackexchange.com/a/181470/111042. See comment by vklidu under your question. $\endgroup$
    – james_t
    Commented Jan 8, 2023 at 18:16
  • $\begingroup$ I fixed the render problem by changing the "Step" value. But I turned on Liquid and Mesh, and turned off the Camera button in Particles Tab. Still doesn't fix it. (Added Image) $\endgroup$
    – 0cybonysc
    Commented Jan 10, 2023 at 8:53
  • 1
    $\begingroup$ I added the .blend file if it helps. $\endgroup$
    – 0cybonysc
    Commented Jan 10, 2023 at 9:12
  • $\begingroup$ @0cybonysc -- as you'll see I used your file and included some of the render output. Comment on what you do not like. $\endgroup$
    – james_t
    Commented Jan 11, 2023 at 17:16
1
$\begingroup$

Ugh, I have this sort of problem all the time!

I didn't want the stupid domain box to be blocking out everything in the final render, so I set its visibility to not show in the render, and to show as wireframe in the viewport. WRONG!

The domain box is also the fluid surface after you meshify it. You do want the fluid mesh to show, right? So the domain, which appears as a box during the early part of the simulation, renders as a wavy flowy surface only after the liquid particles are meshified.

There's really three (or more) steps to simulating the fluid.

Before any of that, the fluid related objects must be set up.

  • one fluid domain box, set to Liquid (default is gas)
  • one arbitrary object (cube, sphere etc) set as Flow, either Inflow (steady source like a faucet) or Geometry (lump of fluid that will fall onto other things)
  • zero or more objects set as Effectors. Liquid will collide with this, flow around them.

A common mistake (from what I hear others say, anyway, I wouldn't know, heh heh [blushes]) is to forget to set some of the involved objects to "Liquid".

Once the setup is right, the full simulation is done in three steps. As a noob, learn these well by running them separately with the domain's fluid sim cache (near bottom of all the liquid sim's settings) set to "Modular". Apparently "module" is Blender's word for step.

Also in the Cache section, turn on the check box labelled "Is Resumable" or else you'll be stuck forever at step one (Ways To Get Stuck #583).

  1. In the Settings section, click Bake Data. Wait a long time. Then hit spacebar or click the playback play button. If nothing appears, Resolution may be too small a number, or the Inflow/Geometry source object may be too small - it should be bigger than the tiny box in a bottom corner of the domain box. Or any of fifty other things may be haywire.

  2. If you don't want any foam, spray or bubbles, skip this. Unfold the Particles section. Check Foam, Spray and Bubbles, whichever ones you want. Click Bake Particles. Wait. It'll go quicker than the step one computation. Up to three new particle systems will be created. Nothing new will render until you tell these particles systems how to render. If you know about that, cool. If not, find out - it's too much to squeeze into here.

  3. Create a mesh from the liquid particles. Unfold the Mesh section, turn on its checkbox. The default settings are fine for non-experts. Click the Bake Mesh button. Wait. This too will go quicker than step one, but may be slower than step 2. When this is done, in the 3D viewport the domain box will no longer appear. Instead you see orange blob meshes (assuming it's still selected) which, if a material had been applied to the domain box, should render as that material. Of course there are still all the usual ways to mess up a render with no lights, bad camera angle, etc.

Chances are very good I forgot to mention a few things that I had to learn the hard way after hours of fiddling with settings and visiting Blender StackExchange and other Q&A sites. I will edit this answer, or someone will, as those come to light.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .