Okay, so this thing, is for me very strange. It still might be very obvious, but I started with blender 4 days ago.

So what is happening is that when I am rendering my animation, I have a white wall and ground where the scene grid is.

Here is a screenshot when in render mode: enter image description here

And here it is in material mode: enter image description here

I would really like to remove this, and I have tried for hours now with no success. I tried to unlink "world" from the scene but then it got all dark when rendered.

If you have any idea of what could be causing this?

(I am making an animated minecraft intro)

Edit: I was told to do alt + h and then the wall and the ground was visible in material mode as well. Here is a screenshot.

enter image description here

But I can't find a way to delete it... :/

  • $\begingroup$ Try Alt+H to un-hide objects in the viewport. $\endgroup$
    – J Sargent
    Apr 9, 2015 at 22:51
  • $\begingroup$ Ok, now the wall and ground is showing in material mode. $\endgroup$ Apr 9, 2015 at 22:55
  • 2
    $\begingroup$ It looks like a hidden object. The world datablock can't have any mesh data, so it doesn't really make sense for an object to be in it. If you can't select it in the 3D view with RMB, then look in the outliner for an object with selection disabled (mouse pointer icon). $\endgroup$
    – gandalf3
    Apr 9, 2015 at 23:19

2 Answers 2


Not a bug, no black magic needed to get rid of the object.

What you have is an object that cannot be selected. The selectable switch has been disabled.

enter image description here

Enable that, select the object and delete it!

Those icons on the outliner are toggle switches:

Eye to make the object visible in the viewport.

Arrow for selectability

Camera to enable the object for rendering.

Make yourself a favor and read the manual page for the outliner here: https://www.blender.org/manual/editors/outliner.html

  • 2
    $\begingroup$ Is there a shortcut for it like with the Eye and Camera options? $\endgroup$
    – J Sargent
    Apr 10, 2015 at 0:30
  • $\begingroup$ It makes sence, I believed I tried that on actually every object in the scene.. But I might have missed that one, thanks anyways! $\endgroup$ Apr 10, 2015 at 6:04

There is no way to entirely disable World (although you can make it functionally do nothing.) However, you don't need to, because the piece you are having issues with is not World. World contains no geometry, it is only your background color. The piece shown in your images is a piece of geometry, and should be deletable like any other. You just have to find where it is and what its called. Try looking in the Outliner, and keep in mind that if the Arrow (looks like a mouse pointer) next to something is disabled, then it cannot be selected until you re-enable it. It could also be hiding on other render layers.

If you share your file, we can help you figure out the problem piece. EDIT: Upon reviewing file, it was a piece called "Plane".

  • $\begingroup$ Here is the file mediafire.com/download/b92gnjzu3eamezc/shared.blend $\endgroup$ Apr 10, 2015 at 0:03
  • $\begingroup$ I can't select it either. Very interesting. @drudge That isn't really an answer necesarily $\endgroup$
    – J Sargent
    Apr 10, 2015 at 0:11
  • $\begingroup$ @NoviceInDisguise Let me know if you figure it out? (If you feel like trying of course) I am going to bed now so hopefully someone have come up with a solution tomorrow :/ $\endgroup$ Apr 10, 2015 at 0:13
  • $\begingroup$ I will, this is very odd behavior, so I'm afraid it might be a bug. I will be sure to let you know what I find though. $\endgroup$
    – J Sargent
    Apr 10, 2015 at 0:14
  • $\begingroup$ It is a piece simply called "Plane" that is set as unselectable in the outliner. Check the Arrow and you can then select and delete it. @NoviceInDisguise: It's an accurate answer to the original question, which was in regards to World. And it turns out to have been accurate to the real issue as well. I have updated it. $\endgroup$
    – Ascalon
    Apr 10, 2015 at 0:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .