Is there any way to render with Radeon RX 6000 series graphic card with Blender 3.4 under linux? After 2 days of trying diferent kernel/amdgpu driver combinations finally it seem that driver is installed.

Vendor: AMD
    Version: 22.3.0
    Accelerated: yes

However, Blender still does not display the graphic card in the preferences window even though the driver version (22.3) is higher than required (22.1)

Kernel: 5.15.0-57-generic Ubuntu 20.4 LTS

AMD driver: 22.40 for Ubuntu 20.4 LTS

Is this an AMD driver or Blender fault? What else can i do to make it work?


1 Answer 1


Partially solved that way:

1.install Ubuntu 20.4.1 LTS
2.install AMD GPU driver installer from AMD site (it was 22.40 for me)
3.install all updates and upgrade your Ubuntu with system upgrade tool
4.sudo amdgpu-install --usecase=graphics,opencl --vulkan=amdvlk --opencl=legacy (it can show missing .bin files but dont care)
5.sudo apt-get update
6.sudo apt-get upgrade
8.sudo apt-get install mesa-utils
9.sudo amdgpu-install -y (and reboot if needed)
10.sudo ./blender

Card should be visible in Blender properties tab then. It is working but running with '''sudo''' it is not OK :)

  • $\begingroup$ Are you sure you want to run Blender with sudo privileges? Or is that the only way that the GPU is properly recognized in Blender? If so, then you should take a closer look at the permissions. ...or am I missing something here? $\endgroup$
    – quellenform
    Jan 6, 2023 at 21:37
  • $\begingroup$ No, it is the only way it worked so far. Tried to add user to "render" and "video" groups with sudo usermod -a -G $GROUP $USERNAME but with no luck. $\endgroup$
    – 3dnotguru
    Jan 7, 2023 at 23:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .