4
$\begingroup$

So I have a "twisted" cube that I rendered an image from, as shown below:

enter image description here

I was wondering if there is a way to smooth out the diagonal lines on the cubes faces.

$\endgroup$
  • 2
    $\begingroup$ Set the smoothing to smooth and in the mesh properties check the autosmooth option and set the angle for cca. 60°. You should also densify the geometry $\endgroup$ – Jaroslav Jerryno Novotny Apr 9 '15 at 14:35
  • 1
    $\begingroup$ What he said ^^ A face is treated as two triangle internally in Blender for rendering and such otherwise $\endgroup$ – VRM Apr 9 '15 at 14:37
  • $\begingroup$ or you can simplesubsurf it. $\endgroup$ – Scalia Apr 9 '15 at 19:06
  • $\begingroup$ Just because I want to learn, and understand... This is because the middle edge is marked as sharp? $\endgroup$ – EJTH Apr 9 '15 at 20:53
  • $\begingroup$ Yes, setting it to smooth should fix that issue. $\endgroup$ – VRM Apr 10 '15 at 2:45
3
$\begingroup$

Every quad is treated as 2 triangles, this is what is causing the problem. You need smooth shading for the edges inside the quads and sharp for the corners of the cube.

To do this set the smoothing to smooth and in the mesh properties check the auto-smooth option and set the angle for cca. 70° (depends on the twisting).

enter image description here

enter image description here

This way faces with angle with more than 70° will keep sharp shading between them.

You should also densify the geometry so it follows the ideal curved/bended surface closer.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.