0
$\begingroup$

I am working an animation with simple particle emitter, the object has a complex glass shader to bring refraction and a bit of rgb separation.

The problem is that when the particles overlap, which is the intended idea, the noise is too high, and the denoiser can not calculate properly, as far as I understand.

I tried many solutions, tricks and I dont think any has worked. From render settings to changing types of lights and still get the same results.

this image show that one or two objects have no problem with the denoiser this image shows how when the particles (a lid) overlap, the denoiser works pretty random without denoiser is pretty noisy already

Please, I would like to understand how to make a more efficient render with less noise, but also how to improve the way the de-noiser behaves.

Thank you!

$\endgroup$
6
  • $\begingroup$ Hello ! Have you tried bumping up the number of samples ? What are you rendering at ? $\endgroup$
    – Gorgious
    Commented Jan 3, 2023 at 10:41
  • $\begingroup$ Hi Gorgious, yeah I tried to render with several combinations, 300, 1000, 2000 w/o denoiser, and the result is pretty much the same. So I went back to 300 and trying other settings. $\endgroup$ Commented Jan 3, 2023 at 11:26
  • $\begingroup$ You might want to explore ways to reduce noise and fireflies, there are a number of tutorials out there. For instance it seems you're using an HDRI, they produce nice lighting but at the cost of extra computation. Try with a simple sun light for example. $\endgroup$
    – Gorgious
    Commented Jan 3, 2023 at 13:26
  • $\begingroup$ I checked many tutorials on how to reduce the noise before using de-noiser; adjusting light path, noise threshold, BVH, persistent data, samples, and denoising settings. Haven't found any good lead. Regarding HDRI, I am using the HDRI as visible backdrop since the rotation of the camera is 360 it helps to be visible, since the objects are transparent also is important to see whats behind. Also throwing some light with emitters (also tried area-lights instead). Not much has helped, just an insane amount of samples but the denoiser creates a overly smooth look that I dont like. $\endgroup$ Commented Jan 3, 2023 at 13:43
  • $\begingroup$ I think it may be the glass shader I am using because is not just the basic glass, there is a white noise to help create a bit of iridescent look. $\endgroup$ Commented Jan 3, 2023 at 14:18

0

You must log in to answer this question.