I am animating some characters and my framerate is tanking. I have been troubleshooting a lot and have found that even when a collection containing a character's meshes and rig is completely disabled both via the "Exclude from View Layer" checkmark and the "Disable in Viewport" monitor box, I don't get nearly as much savings in framerate as I do by just deleting.

This is what I mean by "completely disabled": enter image description here

For instance, right now with 1 character completely disabled, I get 18 FPS in viewport. When I simply delete the collection completely, The framerate jumps to 24 FPS.

I have also noticed that with modifiers like geometry nodes and shrinkwrap, even if they are disabled in viewport, they still cut my framerate substantially until I completely remove them.

Is there no way in Blender to actually disable objects and collisions to have Blender completely skip over processing them? I feel like this makes Blender completely nonviable for professional use. I am only animating 2 characters and I can not even focus on one at a time with a standard 24 FPS. It does not help even if I switch to mannequins with no Armature modifiers in sight (again, until I completely delete the characters).



You must log in to answer this question.