So I was working on a model and at some point while working on a part I mistyped and all the other meshes disappeared (except for the one I was working on) the problem is : I can't get them to show back. I tried undoing but it didn't work. They are still in the menu on the side and they don't have any special status or anything. Everything is normal on a that menu. But when I click on them and go in edit mode it's as if the mesh doesn't exist (the coordinates and other things don't appear in the transform tab even if I press A in Edit mode)

I am a big noob so I'm not generally suprised when something goes wrong. But here because I don't remember what key I accidentally pressed I can't really find an solution. Thank you for your time !

Edit : Someone suggested I share my blend file so here is a link It's a mediafire download

  • $\begingroup$ No chance you just hid the mesh parts by mistake? Try Alt+H (unhide) in both object and edit mode just to be sure. $\endgroup$ Dec 31, 2022 at 16:51
  • $\begingroup$ It's not that. I tried again to be sure but nothing changed. $\endgroup$ Dec 31, 2022 at 16:56
  • $\begingroup$ can be a lot of reasons. Best would be to provide your blend file. But you could start with providing a screenshot of your blender file so we can see your outliner and view3d $\endgroup$
    – Chris
    Dec 31, 2022 at 17:03
  • $\begingroup$ Edited to add a link to my blendfile, you can download it through that link (It's mediafire tho, hope you don't mind. I can try to find another site if needed). $\endgroup$ Dec 31, 2022 at 17:15
  • $\begingroup$ You can share your blend file here in future: blend-exchange.com. $\endgroup$
    – John Eason
    Dec 31, 2022 at 17:45

1 Answer 1


You're in Local mode (as shown top left in the viewport). Hit / (forward slash on the numpad) to get back into normal mode.

enter image description here

  • $\begingroup$ Thank you ! and thank you for the explanations as well, it helps a lot. $\endgroup$ Dec 31, 2022 at 18:01
  • $\begingroup$ No problem. It's easy to hit that key by mistake while changing views with the numpad. It's also available on the View menu as 'Local View > Toggle Local view'. $\endgroup$
    – John Eason
    Dec 31, 2022 at 19:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .