In video at ArtStation the teacher uses the screw modifier, then he goes into edit mode and the generated geometry wireframe still shows:

Edit Mode with wireframe


I have wireframe enabled under viewport overlays and see the wireframe (with solid viewport shading) in object mode: Object Mode

However in edit mode I only get this: Edit Mode

Under object properties / viewport display I also tried enabling wireframe (which seems to do the same as wireframe setting under viewport overlays, just per object) and all edges, but that did not help. I'm using a later version than the teacher, was this functionality removed? I cannot find any option to turn it on. Any ideas?

  • 1
    $\begingroup$ Yeah, that's strange, it seems screw generated geometry does not show wires in wireframe mode (before the modifier is applied). I can not find a way to get it to display. Could you take a screenshot of the moment he activates it in the video? - The video you linked is locked for those who do not have an account. $\endgroup$ Dec 31, 2022 at 1:28
  • $\begingroup$ I just added screenshot from video showing him in edit mode with wireframe showing, but it was screenshotted from my phone, not the best quality. $\endgroup$ Dec 31, 2022 at 1:30
  • $\begingroup$ Can confirm that it seems to work like described in older versions (I tried a fresh install 2.93, the one in the video is 3.1.2), but not in newer ones. Couldn't find a patch where the change happens though, so maybe it's a bug? Not sure. Could ask the devs after holidays if no one comes with an answer I guess. $\endgroup$
    – Kuboå
    Dec 31, 2022 at 1:40
  • 1
    $\begingroup$ Earliest version it stops working seems to be 3.4, when the Viewer Node option was added to the overlays, I'm assuming that's the culprit. $\endgroup$
    – Kuboå
    Dec 31, 2022 at 2:03


You must log in to answer this question.

Browse other questions tagged .