1
$\begingroup$

I have this model I have imported in Blender. The UV map is quite dirty and I have the following texture paint as you can see. However when I zoom out some seams appear where there are separations on the UV map. How can I fix this? Please note that I am very new to Blender.

enter image description here

$\endgroup$
3
  • $\begingroup$ Texture bleeding? Can you share the blend file? Go into edit mode and select the face(s) with the bleed. then in UV editor you can try adjust the position of the mapping or its scale. blend-exchange.com $\endgroup$ Dec 30, 2022 at 15:35
  • $\begingroup$ @HarryMcKenzie I uploaded it $\endgroup$
    – Julien
    Dec 30, 2022 at 16:32
  • $\begingroup$ You need to post the link that is displayed after the upload. Otherwise, no one can access the file ;-) -- About your question, the margin around the UV islands might be too small as Harry McKenzie wrote. As an alternative to scaling, you can try re-baking the image and creating an image texture with a larger margin. (Image Texture node -> Emission node, then bake with Bake Type: Emit and increase Margin in the bake settings). $\endgroup$
    – Blunder
    Dec 30, 2022 at 20:36

1 Answer 1

2
$\begingroup$

This looks like the results of insufficient margins in your texture relative to your models' UVs. In the Image Editor in paint mode, if you turn on the Display Paint Texture Paint UVs overlay, you can easily see where your painting is relative to the mesh's UVs:

overlay

margin

When you go away from your model, the viewport uses mipmapping to reduce the displayed texture resolution and use less resources. But because your painting margin is too small, the mipmap downresolutions quickly display your texture's white background.

mipmapping example

Source: Edge padding - polycount

A first easy way to fix the texture as is would be to just change that white background color to the greyish blue (HEX code #2E394C) you have almost everywhere, using the Fill brush:

color fix

For further texture paintings:

Do remember to set a higher Bleeding in the viewport's Sidebar > Tools tab > Options panel:

bleeding

This will make your brush strokes in the viewport automatically "bleed" by a certain amount outside your meshe's UV islands, reducing the risk of seeing the wrong color when your model is viewed from afar.

If you paint from the Image Editor instead of the viewport, you won't have any automatic bleeding but you can manually paint the margin anyway.

Make sure you always have some paint outside your UVs so to avoid the issue.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .